# CVE-2024-27181: Apache Linkis Basic management services: Privilege Escalation Attack vulnerability

> A trusted user can escalate privileges to access sensitive token information in Apache Linkis basic management services.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2024
- **Updated:** 12 Aug 2024
- **Also known as:** GHSA-v352-rg37-5q5m

## What is CVE-2024-27181?

CVE-2024-27181 is a high-severity vulnerability in Apache Linkis Basic management services, published on 2 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Linkis <= 1.5.0,

Privilege Escalation in Basic management services where the attacking user is 

a trusted account

 allows access to Linkis's Token information. Users are advised to upgrade to version 1.6.0, which fixes this issue.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-27181?

2 open source packages ship an affected version, including org.apache.linkis:linkis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.linkis:linkis` | Maven | All versions | 1.6.0 |
| `org.apache.linkis:linkis` | Maven | All versions | 1.6.0 |

Products: Apache Linkis.

## How do I fix CVE-2024-27181?

Upgrade org.apache.linkis:linkis to 1.6.0 or later.

## Is CVE-2024-27181 being exploited?

There is no known exploitation of CVE-2024-27181 in the wild and no public exploit code.

## Other vulnerabilities in Apache Linkis Basic management services

- [CVE-2023-27602](https://insights.sbomify.com/CVE-2023-27602/): Apache Linkis publicsercice module unrestricted upload of file (critical 9.8)
- [CVE-2023-27603](https://insights.sbomify.com/CVE-2023-27603/): Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue (critical 9.8)
- [CVE-2023-29215](https://insights.sbomify.com/CVE-2023-29215/): Apache Linkis JDBC EngineCon has a deserialization command execution (critical 9.8)
- [CVE-2023-29216](https://insights.sbomify.com/CVE-2023-29216/): Apache Linkis DatasourceManager module has a deserialization command execution (critical 9.8)
- [CVE-2023-27987](https://insights.sbomify.com/CVE-2023-27987/): Apache Linkis gateway module token authentication bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27181 and fix it if it is affected.

What it is: CVE-2024-27181 is a high-severity vulnerability in Apache Linkis Basic management services, published on 2 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27181 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.linkis:linkis (Maven): affected all versions; fixed in 1.6.0
- org.apache.linkis:linkis (Maven): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27181/ (Markdown: https://insights.sbomify.com/CVE-2024-27181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27181
- OSV: https://osv.dev/vulnerability/CVE-2024-27181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27181/
Summaries are generated and may contain mistakes; the official description above is the record.
