# CVE-2024-27187: [20240804] - Core - Improper ACL for backend profile view

> Backend users can improperly overwrite their usernames due to flawed access controls, requiring administrators to patch the Joomla CMS.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2024
- **Updated:** 22 Aug 2024
- **Also known as:** BIT-joomla-2024-27187, GHSA-6pqq-98x8-92qf

## What is CVE-2024-27187?

CVE-2024-27187 is a high-severity missing authorization vulnerability in Joomla Joomla\!, published on 20 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Access Controls allows backend users to overwrite their username when disallowed.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-27187?

1 open source package ship an affected version, including joomla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla` | Bitnami | From 4.0.0 | 5.1.3 |

Products: Joomla Joomla\!.

## How do I fix CVE-2024-27187?

Upgrade joomla to 5.1.3 or later.

## Is CVE-2024-27187 being exploited?

There is no known exploitation of CVE-2024-27187 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27187 and fix it if it is affected.

What it is: CVE-2024-27187 is a high-severity missing authorization vulnerability in Joomla Joomla\!, published on 20 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27187 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla (Bitnami): affected from 4.0.0; fixed in 5.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27187/ (Markdown: https://insights.sbomify.com/CVE-2024-27187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27187
- OSV: https://osv.dev/vulnerability/CVE-2024-27187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27187/
Summaries are generated and may contain mistakes; the official description above is the record.
