{"answers":{"affected":"8 open source packages ship an affected version, including rdoc.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27281 exists.","fix":"Upgrade rdoc to a fixed version for your release line: 6.3.4.1, 6.4.1.1, 6.5.1.1 or 6.6.3.1.","what":"CVE-2024-27281 is a medium-severity unsafe deserialization vulnerability in n/a, published on 8 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-27281 and fix it if it is affected.\n\nWhat it is: CVE-2024-27281 is a medium-severity unsafe deserialization vulnerability in n/a, published on 8 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27281 exists.\n\nAffected packages and fixed versions:\n- rdoc (RubyGems): affected from 6.3.3; fixed in 6.3.4.1\n- rdoc (RubyGems): affected from 6.3.3; fixed in 6.3.4.1\n- rdoc (RubyGems): affected from 6.4.0; fixed in 6.4.1.1\n- rdoc (RubyGems): affected from 6.4.0; fixed in 6.4.1.1\n- rdoc (RubyGems): affected from 6.5.0; fixed in 6.5.1.1\n- rdoc (RubyGems): affected from 6.5.0; fixed in 6.5.1.1\n- rdoc (RubyGems): affected from 6.6.0; fixed in 6.6.3.1\n- rdoc (RubyGems): affected from 6.6.0; fixed in 6.6.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27281/ (Markdown: https://insights.sbomify.com/CVE-2024-27281/index.md)","id":"CVE-2024-27281","markdown":"https://insights.sbomify.com/CVE-2024-27281/index.md","name":"CVE-2024-27281","record":{"aliases":["ALPINE-CVE-2024-27281","AZL-40523","AZL-40675","BELL-CVE-2024-27281","CLEANSTART-2026-GN52279","CLSA-2025-1753375058","DEBIAN-CVE-2024-27281","GHSA-592j-995h-p23j","UBUNTU-CVE-2024-27281","USN-6838-2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby documentation library","requires_auth":"none","summary":"Attackers can achieve remote code execution by exploiting unsafe YAML deserialization in RDoc configuration files or documentation caches.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":4.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdoc_options (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. (When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache.) The main fixed version is 6.6.3.1. For Ruby 3.0 users, a fixed version is rdoc 6.3.4.1. For Ruby 3.1 users, a fixed version is rdoc 6.4.1.1. For Ruby 3.2 users, a fixed version is rdoc 6.5.1.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"RDoc RCE vulnerability with .rdoc_options","id":"CVE-2024-27281","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":8,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2024-27282"},"packages":[{"ecosystem":"RubyGems","fixed":["6.3.4.1"],"introduced":["6.3.3"],"last_affected":[],"package":"rdoc","purl":null,"source":"GHSA-592j-995h-p23j"},{"ecosystem":"RubyGems","fixed":["6.3.4.1"],"introduced":["6.3.3"],"last_affected":[],"package":"rdoc","purl":"pkg:gem/rdoc","source":"GHSA-592j-995h-p23j"},{"ecosystem":"RubyGems","fixed":["6.4.1.1"],"introduced":["6.4.0"],"last_affected":[],"package":"rdoc","purl":null,"source":"GHSA-592j-995h-p23j"},{"ecosystem":"RubyGems","fixed":["6.4.1.1"],"introduced":["6.4.0"],"last_affected":[],"package":"rdoc","purl":"pkg:gem/rdoc","source":"GHSA-592j-995h-p23j"},{"ecosystem":"RubyGems","fixed":["6.5.1.1"],"introduced":["6.5.0"],"last_affected":[],"package":"rdoc","purl":null,"source":"GHSA-592j-995h-p23j"},{"ecosystem":"RubyGems","fixed":["6.5.1.1"],"introduced":["6.5.0"],"last_affected":[],"package":"rdoc","purl":"pkg:gem/rdoc","source":"GHSA-592j-995h-p23j"},{"ecosystem":"RubyGems","fixed":["6.6.3.1"],"introduced":["6.6.0"],"last_affected":[],"package":"rdoc","purl":null,"source":"GHSA-592j-995h-p23j"},{"ecosystem":"RubyGems","fixed":["6.6.3.1"],"introduced":["6.6.0"],"last_affected":[],"package":"rdoc","purl":"pkg:gem/rdoc","source":"GHSA-592j-995h-p23j"}],"prev":{"headline":"StringIO buffer overread vulnerability","id":"CVE-2024-27280"},"products":["n/a"],"published":"2024-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["n/a"]},"summary":"Attackers can achieve remote code execution by exploiting unsafe YAML deserialization in RDoc configuration files or documentation caches.","url":"https://insights.sbomify.com/CVE-2024-27281/"}