CVE-2024-27282 Information disclosure in n/a
Attackers can extract arbitrary heap data, including pointers and sensitive strings, by supplying malicious data to the Ruby regex compiler.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-27282?
CVE-2024-27282 is a medium-severity vulnerability in n/a, published on 8 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.
Weakness: CWE-125
Which versions are affected by CVE-2024-27282?
2 open source packages ship an affected version, including ruby and ruby-min.
| Package | Affected | Fixed in |
|---|---|---|
ruby Bitnami | All versions | 3.1.5, 3.2.4, 3.3.1 |
ruby-min Bitnami | All versions | 3.1.6, 3.2.6, 3.3.7 |
How do I fix CVE-2024-27282?
Upgrade ruby to a fixed version for your release line: 3.1.5, 3.2.4 or 3.3.1.
Is CVE-2024-27282 being exploited?
There is no known exploitation of CVE-2024-27282 in the wild and no public exploit code.
Sources
Also known as ALPINE-CVE-2024-27282, AZL-40520, AZL-40733, BELL-CVE-2024-27282, BIT-ruby-2024-27282, BIT-ruby-min-2024-27282 and 10 more.