{"answers":{"affected":"2 open source packages ship an affected version, including ruby and ruby-min.","exploited":"There is no known exploitation of CVE-2024-27282 in the wild and no public exploit code.","fix":"Upgrade ruby to a fixed version for your release line: 3.1.5, 3.2.4 or 3.3.1.","what":"CVE-2024-27282 is a medium-severity vulnerability in n/a, published on 8 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-27282 and fix it if it is affected.\n\nWhat it is: CVE-2024-27282 is a medium-severity vulnerability in n/a, published on 8 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-27282 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ruby (Bitnami): affected all versions; fixed in 3.1.5, 3.2.4, 3.3.1\n- ruby-min (Bitnami): affected all versions; fixed in 3.1.6, 3.2.6, 3.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27282/ (Markdown: https://insights.sbomify.com/CVE-2024-27282/index.md)","id":"CVE-2024-27282","markdown":"https://insights.sbomify.com/CVE-2024-27282/index.md","name":"CVE-2024-27282","record":{"aliases":["ALPINE-CVE-2024-27282","AZL-40520","AZL-40733","BELL-CVE-2024-27282","BIT-ruby-2024-27282","BIT-ruby-min-2024-27282","CLEANSTART-2026-LA33786","DEBIAN-CVE-2024-27282","GHSA-63cq-cj6g-qfr2","OESA-2024-1545","OESA-2024-1607","OESA-2024-1608","OESA-2024-1609","OESA-2024-1610","OESA-2024-1611","UBUNTU-CVE-2024-27282"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby programming language","requires_auth":"none","summary":"Attackers can extract arbitrary heap data, including pointers and sensitive strings, by supplying malicious data to the Ruby regex compiler.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.6,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in n/a","id":"CVE-2024-27282","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"File upload in n/a","id":"CVE-2024-27283"},"packages":[{"ecosystem":"Bitnami","fixed":["3.1.5","3.2.4","3.3.1"],"introduced":["0","3.2.0","3.3.0"],"last_affected":[],"package":"ruby","purl":"pkg:bitnami/ruby","source":"BIT-ruby-2024-27282"},{"ecosystem":"Bitnami","fixed":["3.1.6","3.2.6","3.3.7"],"introduced":["0","3.2.0","3.3.0"],"last_affected":[],"package":"ruby-min","purl":"pkg:bitnami/ruby-min","source":"BIT-ruby-min-2024-27282"}],"prev":{"headline":"RDoc RCE vulnerability with .rdoc_options","id":"CVE-2024-27281"},"products":["n/a"],"published":"2024-05-08","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["n/a"]},"summary":"Attackers can extract arbitrary heap data, including pointers and sensitive strings, by supplying malicious data to the Ruby regex compiler.","url":"https://insights.sbomify.com/CVE-2024-27282/"}