CVE-2024-27284 cassandra-rs non-idiomatic use of iterators leads to use after free

High 7.5 Published Updated

Attackers can trigger undefined behavior via use-after-free in the cassandra-rs library by misusing iterators, potentially leading to crashes or code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-27284?

CVE-2024-27284 is a high-severity use after free vulnerability in Metaswitch cassandra-rs, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

cassandra-rs is a Cassandra (CQL) driver for Rust. Code that attempts to use an item (e.g., a row) returned by an iterator after the iterator has advanced to the next item will be accessing freed memory and experience undefined behaviour. The problem has been fixed in version 3.0.0.

Weakness: CWE-416

Which versions are affected by CVE-2024-27284?

3 open source packages ship an affected version, including cassandra-cpp. It affects 1 product.

PackageAffectedFixed in
cassandra-cpp crates.ioAll versions3.0.0
cassandra-cpp crates.ioAll versions3.0.0
cassandra-cpp crates.ioFrom 0.0.0-03.0.0

Products include Cassandra-Rs Project Cassandra-Rs.

How do I fix CVE-2024-27284?

Upgrade cassandra-cpp to 3.0.0 or later.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2024-27284 being exploited?

There is no known exploitation of CVE-2024-27284 in the wild and no public exploit code.

Sources

Also known as GHSA-x9xc-63hg-vcfq, RUSTSEC-2024-0017.

Is CVE-2024-27284 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free