# CVE-2024-27284: cassandra-rs non-idiomatic use of iterators leads to use after free

> Attackers can trigger undefined behavior via use-after-free in the cassandra-rs library by misusing iterators, potentially leading to crashes or code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2024
- **Updated:** 12 Aug 2024
- **Also known as:** GHSA-x9xc-63hg-vcfq, RUSTSEC-2024-0017

## What is CVE-2024-27284?

CVE-2024-27284 is a high-severity use after free vulnerability in Metaswitch cassandra-rs, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cassandra-rs is a Cassandra (CQL) driver for Rust. Code that attempts to use an item (e.g., a row) returned by an iterator after the iterator has advanced to the next item will be accessing freed memory and experience undefined behaviour.  The problem has been fixed in version 3.0.0.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2024-27284?

3 open source packages ship an affected version, including cassandra-cpp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cassandra-cpp` | crates.io | All versions | 3.0.0 |
| `cassandra-cpp` | crates.io | All versions | 3.0.0 |
| `cassandra-cpp` | crates.io | From 0.0.0-0 | 3.0.0 |

Products: Cassandra-Rs Project Cassandra-Rs.

## How do I fix CVE-2024-27284?

Upgrade cassandra-cpp to 3.0.0 or later.

## Is CVE-2024-27284 being exploited?

There is no known exploitation of CVE-2024-27284 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27284 and fix it if it is affected.

What it is: CVE-2024-27284 is a high-severity use after free vulnerability in Metaswitch cassandra-rs, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27284 in the wild and no public exploit code.

Affected packages and fixed versions:
- cassandra-cpp (crates.io): affected all versions; fixed in 3.0.0
- cassandra-cpp (crates.io): affected all versions; fixed in 3.0.0
- cassandra-cpp (crates.io): affected from 0.0.0-0; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27284/ (Markdown: https://insights.sbomify.com/CVE-2024-27284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27284
- OSV: https://osv.dev/vulnerability/CVE-2024-27284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27284/
Summaries are generated and may contain mistakes; the official description above is the record.
