{"answers":{"affected":"2 open source packages ship an affected version, including yard. It affects 3 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27285 exists.","fix":"Upgrade yard to 0.9.36 or later.","what":"CVE-2024-27285 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-27285 and fix it if it is affected.\n\nWhat it is: CVE-2024-27285 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27285 exists.\n\nAffected packages and fixed versions:\n- yard (RubyGems): affected all versions; fixed in 0.9.36\n- yard (RubyGems): affected all versions; fixed in 0.9.36\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27285/ (Markdown: https://insights.sbomify.com/CVE-2024-27285/index.md)","id":"CVE-2024-27285","markdown":"https://insights.sbomify.com/CVE-2024-27285/index.md","name":"CVE-2024-27285","record":{"aliases":["DEBIAN-CVE-2024-27285","DSA-5635-1","GHSA-8mq4-9jjh-9xrc","OESA-2024-1256","UBUNTU-CVE-2024-27285"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby documentation tool","requires_auth":"none","summary":"YARD's default template allows Cross-Site Scripting via unsanitized input in generated frames.html, enabling attackers to execute scripts in users' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"yard","vendor":"yardoc"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"YARD is a Ruby Documentation tool. The \"frames.html\" file within the Yard Doc's generated documentation is vulnerable to Cross-Site Scripting (XSS) attacks due to inadequate sanitization of user input within the JavaScript segment of the \"frames.erb\" template file.  This vulnerability is fixed in 0.9.36.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"YARD's default template vulnerable to Cross-site Scripting in generated frames.html","id":"CVE-2024-27285","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"xss","year":"2024"},"n_packages":2,"n_references":7,"next":{"headline":"Moving single messages from public to private streams leaves them accessible","id":"CVE-2024-27286"},"packages":[{"ecosystem":"RubyGems","fixed":["0.9.36"],"introduced":["0"],"last_affected":[],"package":"yard","purl":null,"source":"GHSA-8mq4-9jjh-9xrc"},{"ecosystem":"RubyGems","fixed":["0.9.36"],"introduced":["0"],"last_affected":[],"package":"yard","purl":"pkg:gem/yard","source":"GHSA-8mq4-9jjh-9xrc"}],"prev":{"headline":"cassandra-rs non-idiomatic use of iterators leads to use after free","id":"CVE-2024-27284"},"products":["yard"],"published":"2024-02-28","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["lsegal"]},"summary":"YARD's default template allows Cross-Site Scripting via unsanitized input in generated frames.html, enabling attackers to execute scripts in users' browsers.","url":"https://insights.sbomify.com/CVE-2024-27285/"}