# CVE-2024-27285: YARD's default template vulnerable to Cross-site Scripting in generated frames.html

> YARD's default template allows Cross-Site Scripting via unsanitized input in generated frames.html, enabling attackers to execute scripts in users' browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2024-27285, DSA-5635-1, GHSA-8mq4-9jjh-9xrc, OESA-2024-1256, UBUNTU-CVE-2024-27285

## What is CVE-2024-27285?

CVE-2024-27285 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

YARD is a Ruby Documentation tool. The "frames.html" file within the Yard Doc's generated documentation is vulnerable to Cross-Site Scripting (XSS) attacks due to inadequate sanitization of user input within the JavaScript segment of the "frames.erb" template file.  This vulnerability is fixed in 0.9.36.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-27285?

2 open source packages ship an affected version, including yard. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yard` | RubyGems | All versions | 0.9.36 |
| `yard` | RubyGems | All versions | 0.9.36 |

Products: Debian Debian Linux, Fedoraproject Fedora, Yardoc Yard.

## How do I fix CVE-2024-27285?

Upgrade yard to 0.9.36 or later.

## Is CVE-2024-27285 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27285 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27285 and fix it if it is affected.

What it is: CVE-2024-27285 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27285 exists.

Affected packages and fixed versions:
- yard (RubyGems): affected all versions; fixed in 0.9.36
- yard (RubyGems): affected all versions; fixed in 0.9.36

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27285/ (Markdown: https://insights.sbomify.com/CVE-2024-27285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27285
- OSV: https://osv.dev/vulnerability/CVE-2024-27285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27285/
Summaries are generated and may contain mistakes; the official description above is the record.
