# CVE-2024-27291: Docassemble open redirect

> An attacker can craft a URL that redirects users to malicious sites, potentially facilitating phishing attacks against Docassemble users.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Feb 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-7wxf-r2qv-9xwr, PYSEC-2026-1310

## What is CVE-2024-27291?

CVE-2024-27291 is a medium-severity vulnerability in jhpyle docassemble, published on 29 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Docassemble is an expert system for guided interviews and document assembly. Prior to 1.4.97, it is possible to create a URL that acts as an open redirect. The vulnerability has been patched in version 1.4.97 of the master branch.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2024-27291?

3 open source packages ship an affected version, including docassemble-webapp and docassemble.webapp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docassemble-webapp` | PyPI | All versions | 1.4.97 |
| `docassemble-webapp` | PyPI | All versions | 1.4.97 |
| `docassemble.webapp` | PyPI | All versions | 1.4.97 |

Products: Jhpyle Docassemble.

## How do I fix CVE-2024-27291?

Upgrade docassemble-webapp to 1.4.97 or later.

## Is CVE-2024-27291 being exploited?

There is no known exploitation of CVE-2024-27291 in the wild and no public exploit code.

## Other vulnerabilities in jhpyle docassemble

- [CVE-2024-27292](https://insights.sbomify.com/CVE-2024-27292/): Docassemble unauthorized access through URL manipulation (high 7.5)
- [CVE-2024-27290](https://insights.sbomify.com/CVE-2024-27290/): Docassemble HTML and javascript injection (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27291 and fix it if it is affected.

What it is: CVE-2024-27291 is a medium-severity vulnerability in jhpyle docassemble, published on 29 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-27291 in the wild and no public exploit code.

Affected packages and fixed versions:
- docassemble-webapp (PyPI): affected all versions; fixed in 1.4.97
- docassemble-webapp (PyPI): affected all versions; fixed in 1.4.97
- docassemble.webapp (PyPI): affected all versions; fixed in 1.4.97

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27291/ (Markdown: https://insights.sbomify.com/CVE-2024-27291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27291
- OSV: https://osv.dev/vulnerability/CVE-2024-27291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27291/
Summaries are generated and may contain mistakes; the official description above is the record.
