# CVE-2024-27292: Docassemble unauthorized access through URL manipulation

> Attackers can gain unauthorized access to system information via URL manipulation in Docassemble, requiring a patch to secure data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Feb 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-jq57-3w7p-vwvv, PYSEC-2026-1309, PYSEC-2026-2453

## What is CVE-2024-27292?

CVE-2024-27292 is a high-severity missing authorization vulnerability in jhpyle docassemble, published on 29 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Docassemble is an expert system for guided interviews and document assembly. The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. The vulnerability has been patched in version 1.4.97 of the master branch.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2024-27292?

6 open source packages ship an affected version, including docassemble-base, docassemble-webapp and docassemble.base. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docassemble-base` | PyPI | From 1.4.53 | 1.4.97 |
| `docassemble-base` | PyPI | From 1.4.53 | 1.4.97 |
| `docassemble-webapp` | PyPI | From 1.4.53 | 1.4.97 |
| `docassemble-webapp` | PyPI | From 1.4.53 | 1.4.97 |
| `docassemble.base` | PyPI | From 1.4.53 | 1.4.97 |
| `docassemble.webapp` | PyPI | From 1.4.53 | 1.4.97 |

Products: Jhpyle Docassemble.

## How do I fix CVE-2024-27292?

Upgrade docassemble-base to 1.4.97 or later.

## Is CVE-2024-27292 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27292 exists.

Public exploit code:

- CVE-2024-27292 : Docassemble V1.4.96 Unauthenticated Path Traversal (github_poc): https://github.com/th3gokul/CVE-2024-27292
- Docassemble任意文件读取漏洞(CVE-2024-27292) (github_poc): https://github.com/NingXin2002/Docassemble_poc
- Docassemble - Local File Inclusion (nuclei): http/cves/2024/CVE-2024-27292.yaml

## Other vulnerabilities in jhpyle docassemble

- [CVE-2024-27290](https://insights.sbomify.com/CVE-2024-27290/): Docassemble HTML and javascript injection (medium 6.1)
- [CVE-2024-27291](https://insights.sbomify.com/CVE-2024-27291/): Docassemble open redirect (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27292 and fix it if it is affected.

What it is: CVE-2024-27292 is a high-severity missing authorization vulnerability in jhpyle docassemble, published on 29 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27292 exists.

Affected packages and fixed versions:
- docassemble-base (PyPI): affected from 1.4.53; fixed in 1.4.97
- docassemble-base (PyPI): affected from 1.4.53; fixed in 1.4.97
- docassemble-webapp (PyPI): affected from 1.4.53; fixed in 1.4.97
- docassemble-webapp (PyPI): affected from 1.4.53; fixed in 1.4.97
- docassemble.base (PyPI): affected from 1.4.53; fixed in 1.4.97
- docassemble.webapp (PyPI): affected from 1.4.53; fixed in 1.4.97

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27292/ (Markdown: https://insights.sbomify.com/CVE-2024-27292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27292
- OSV: https://osv.dev/vulnerability/CVE-2024-27292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27292/
Summaries are generated and may contain mistakes; the official description above is the record.
