# CVE-2024-27298: Parse Server literalizeRegexPart SQL Injection

> SQL injection in Parse Server allows attackers to read or modify database contents when using PostgreSQL.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2024
- **Updated:** 22 Aug 2024
- **Also known as:** BIT-parse-2024-27298, GHSA-6927-3vr9-fxf2

## What is CVE-2024-27298?

CVE-2024-27298 is a critical SQL injection vulnerability in Parseplatform Parse-Server, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

parse-server is a Parse Server for Node.js / Express. This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database. The vulnerability has been fixed in 6.5.0 and 7.0.0-alpha.20.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-27298?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 6.5.0 |
| `parse-server` | npm | All versions | 6.5.0 |
| `parse-server` | npm | From 7.0.0-alpha.1 | 7.0.0-alpha.20 |
| `parse-server` | npm | From 7.0.0-alpha.1 | 7.0.0-alpha.20 |
| `parse` | Bitnami | All versions | 6.5.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2024-27298?

Upgrade parse-server to a fixed version for your release line: 6.5.0 or 7.0.0-alpha.20.

## Is CVE-2024-27298 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27298 exists.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)
- [CVE-2022-39396](https://insights.sbomify.com/CVE-2022-39396/): Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27298 and fix it if it is affected.

What it is: CVE-2024-27298 is a critical SQL injection vulnerability in Parseplatform Parse-Server, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27298 exists.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 6.5.0
- parse-server (npm): affected all versions; fixed in 6.5.0
- parse-server (npm): affected from 7.0.0-alpha.1; fixed in 7.0.0-alpha.20
- parse-server (npm): affected from 7.0.0-alpha.1; fixed in 7.0.0-alpha.20
- parse (Bitnami): affected all versions; fixed in 6.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27298/ (Markdown: https://insights.sbomify.com/CVE-2024-27298/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27298
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27298
- OSV: https://osv.dev/vulnerability/CVE-2024-27298

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27298/
Summaries are generated and may contain mistakes; the official description above is the record.
