CVE-2024-27299 phpMyFAQ SQL Injection at "Save News"
Authenticated users can exploit SQL injection in the news author email field to exfiltrate data, take over accounts, or execute code.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-27299?
CVE-2024-27299 is a high-severity SQL injection vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. A SQL injection vulnerability has been discovered in the the "Add News" functionality due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. The vulnerable field lies in the `authorEmail` field which uses PHP's `FILTER_VALIDATE_EMAIL` filter. This filter is insufficient in protecting against SQL injection attacks and should still be properly escaped. However, in this version of phpMyFAQ (3.2.5), this field is not escaped properly can be used together with other fields to fully exploit the SQL injection vulnerability. This vulnerability is fixed in 3.2.6.
Weakness: CWE-89
Which versions are affected by CVE-2024-27299?
2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
Products include Phpmyfaq Phpmyfaq.
How do I fix CVE-2024-27299?
Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2024-27299 being exploited?
There is no known exploitation of CVE-2024-27299 in the wild and no public exploit code.
Other vulnerabilities in Phpmyfaq Phpmyfaq
- CVE-2023-0310 Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq
- CVE-2022-4407 Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- CVE-2017-11187 Security feature bypass in n/a
- CVE-2026-76213 phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- CVE-2026-76214 phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge
Sources
Also known as GHSA-qgxx-4xv5-6hcw.