CVE-2024-27300 phpMyFAQ Stored XSS at user email
An attacker can execute arbitrary JavaScript in another user's session via stored XSS in the email field, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-27300?
CVE-2024-27300 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. The `email` field in phpMyFAQ's user control panel page is vulnerable to stored XSS attacks due to the inadequacy of PHP's `FILTER_VALIDATE_EMAIL` function, which only validates the email format, not its content. This vulnerability enables an attacker to execute arbitrary client-side JavaScript within the context of another user's phpMyFAQ session. This vulnerability is fixed in 3.2.6.
Weakness: CWE-79
Which versions are affected by CVE-2024-27300?
2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
Products include Phpmyfaq Phpmyfaq.
How do I fix CVE-2024-27300?
Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-27300 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27300 exists.
Other vulnerabilities in Phpmyfaq Phpmyfaq
- CVE-2023-0310 Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq
- CVE-2022-4407 Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- CVE-2017-11187 Security feature bypass in n/a
- CVE-2026-76213 phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- CVE-2026-76214 phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge
Sources
Also known as GHSA-q7g6-xfh2-vhpx.