{"answers":{"affected":"2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27300 exists.","fix":"Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.","what":"CVE-2024-27300 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-27300 and fix it if it is affected.\n\nWhat it is: CVE-2024-27300 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27300 exists.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27300/ (Markdown: https://insights.sbomify.com/CVE-2024-27300/index.md)","id":"CVE-2024-27300","markdown":"https://insights.sbomify.com/CVE-2024-27300/index.md","name":"CVE-2024-27300","record":{"aliases":["GHSA-q7g6-xfh2-vhpx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"FAQ web application","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary JavaScript in another user's session via stored XSS in the email field, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. The `email` field in phpMyFAQ's user control panel page is vulnerable to stored XSS attacks due to the inadequacy of PHP's `FILTER_VALIDATE_EMAIL` function, which only validates the email format, not its content. This vulnerability enables an attacker to execute arbitrary client-side JavaScript within the context of another user's phpMyFAQ session. This vulnerability is fixed in 3.2.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ Stored XSS at user email","id":"CVE-2024-27300","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"xss","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Privilege Escalation Abusing installer in SupportApp","id":"CVE-2024-27301"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.6"],"introduced":["3.2.5"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-q7g6-xfh2-vhpx"},{"ecosystem":"Packagist","fixed":["3.2.6"],"introduced":["3.2.5"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-q7g6-xfh2-vhpx"}],"prev":{"headline":"phpMyFAQ SQL Injection at \"Save News\"","id":"CVE-2024-27299"},"products":["phpMyFAQ"],"published":"2024-03-25","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["thorsten"]},"summary":"An attacker can execute arbitrary JavaScript in another user's session via stored XSS in the email field, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2024-27300/"}