# CVE-2024-27309: Apache Kafka: Potential incorrect access control during migration from ZK mode to KRaft mode

> Attackers may bypass access controls during Kafka ZK-to-KRaft migration if specific ACL removal conditions are met, potentially exposing data.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2024
- **Updated:** 30 Jul 2025
- **Also known as:** BIT-kafka-2024-27309, GHSA-79vv-vp32-gpp7, MINI-8p86-3vj3-7g6v, MINI-99cv-369v-992r, ROOT-APP-MAVEN-CVE-2024-27309, UBUNTU-CVE-2024-27309

## What is CVE-2024-27309?

CVE-2024-27309 is a high-severity missing authorization vulnerability in Apache Kafka, published on 12 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

While an Apache Kafka cluster is being migrated from ZooKeeper mode to KRaft mode, in some cases ACLs will not be correctly enforced.

Two preconditions are needed to trigger the bug:
1. The administrator decides to remove an ACL
2. The resource associated with the removed ACL continues to have two or more other ACLs associated with it after the removal.

When those two preconditions are met, Kafka will treat the resource as if it had only one ACL associated with it after the removal, rather than the two or more that would be correct.

The incorrect condition is cleared by removing all brokers in ZK mode, or by adding a new ACL to the affected resource. Once the migration is completed, there is no metadata loss (the ACLs all remain).

The full impact depends on the ACLs in use. If only ALLOW ACLs were configured during the migration, the impact would be limited to availability impact. if DENY ACLs were configured, the impact could include confidentiality and integrity impact depending on the ACLs configured, as the DENY ACLs might be ignored due to this vulnerability during the migration period.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-27309?

3 open source packages ship an affected version, including org.apache.kafka:kafka-metadata and kafka. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kafka:kafka-metadata` | Maven | From 3.5.0 | 3.6.2 |
| `org.apache.kafka:kafka-metadata` | Maven | From 3.5.0 | 3.6.2 |
| `kafka` | Bitnami | From 3.5.0 | 3.5.2, 3.6.2 |

Products: Apache Kafka.

## How do I fix CVE-2024-27309?

Upgrade org.apache.kafka:kafka-metadata to 3.6.2 or later.

## Is CVE-2024-27309 being exploited?

There is no known exploitation of CVE-2024-27309 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kafka

- [CVE-2026-33557](https://insights.sbomify.com/CVE-2026-33557/): Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication (critical 9.1)
- [CVE-2025-27818](https://insights.sbomify.com/CVE-2025-27818/): Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration (high 8.8)
- [CVE-2018-17196](https://insights.sbomify.com/CVE-2018-17196/): Improper Input Validation in Apache Kafka (high 8.8)
- [CVE-2026-35554](https://insights.sbomify.com/CVE-2026-35554/): Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition (high 8.7)
- [CVE-2025-27817](https://insights.sbomify.com/CVE-2025-27817/): Apache Kafka Client: Arbitrary file read and SSRF vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27309 and fix it if it is affected.

What it is: CVE-2024-27309 is a high-severity missing authorization vulnerability in Apache Kafka, published on 12 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27309 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kafka:kafka-metadata (Maven): affected from 3.5.0; fixed in 3.6.2
- org.apache.kafka:kafka-metadata (Maven): affected from 3.5.0; fixed in 3.6.2
- kafka (Bitnami): affected from 3.5.0; fixed in 3.5.2, 3.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27309/ (Markdown: https://insights.sbomify.com/CVE-2024-27309/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27309
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27309
- OSV: https://osv.dev/vulnerability/CVE-2024-27309

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27309/
Summaries are generated and may contain mistakes; the official description above is the record.
