CVE-2024-27315 Apache Superset: Improper error handling on alerts
Authenticated users can trigger database errors via crafted SQL in alerts, potentially exposing sensitive data in error logs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-27315?
CVE-2024-27315 is a medium-severity vulnerability in Apache Superset, published on 28 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An authenticated user with privileges to create Alerts on Alerts & Reports has the capability to generate a specially crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and may inadvertently surface in the error log of the Alert exposing possibly sensitive data.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Weakness: CWE-209
Which versions are affected by CVE-2024-27315?
6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | All versions | 3.0.4, 3.1.1 |
apache-superset PyPI | All versions | 3.0.4 |
apache-superset PyPI | All versions | 3.0.4 |
apache-superset PyPI | From 3.1.0 | 3.1.1 |
apache-superset PyPI | From 3.1.0 | 3.1.1 |
superset Bitnami | All versions | 4.1.1 |
Products include Apache Superset.
How do I fix CVE-2024-27315?
Upgrade apache-superset to a fixed version for your release line: 3.0.4 or 3.1.1.
Is CVE-2024-27315 being exploited?
There is no known exploitation of CVE-2024-27315 in the wild and no public exploit code.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2024-27315, GHSA-h7r6-8qmm-hj5r, PYSEC-2026-1181.