{"answers":{"affected":"6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-27315 in the wild and no public exploit code.","fix":"Upgrade apache-superset to a fixed version for your release line: 3.0.4 or 3.1.1.","what":"CVE-2024-27315 is a medium-severity vulnerability in Apache Superset, published on 28 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27315 and fix it if it is affected.\n\nWhat it is: CVE-2024-27315 is a medium-severity vulnerability in Apache Superset, published on 28 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-27315 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected all versions; fixed in 3.0.4, 3.1.1\n- apache-superset (PyPI): affected all versions; fixed in 3.0.4\n- apache-superset (PyPI): affected all versions; fixed in 3.0.4\n- apache-superset (PyPI): affected from 3.1.0; fixed in 3.1.1\n- apache-superset (PyPI): affected from 3.1.0; fixed in 3.1.1\n- superset (Bitnami): affected all versions; fixed in 4.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27315/ (Markdown: https://insights.sbomify.com/CVE-2024-27315/index.md)","id":"CVE-2024-27315","markdown":"https://insights.sbomify.com/CVE-2024-27315/index.md","name":"CVE-2024-27315","record":{"aliases":["BIT-superset-2024-27315","GHSA-h7r6-8qmm-hj5r","PYSEC-2026-1181"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Superset","requires_auth":"low_privilege","summary":"Authenticated users can trigger database errors via crafted SQL in alerts, potentially exposing sensitive data in error logs.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"An authenticated user with privileges to create Alerts on Alerts \u0026 Reports has the capability to generate a specially crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and may inadvertently surface in the error log of the Alert exposing possibly sensitive data.\n\nThis issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.\n\nUsers are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Superset: Improper error handling on alerts","id":"CVE-2024-27315","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"information_disclosure","year":"2024"},"n_packages":6,"n_references":1,"next":{"headline":"Apache HTTP Server: HTTP/2 DoS by memory exhaustion on endless continuation frames","id":"CVE-2024-27316"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.1"],"introduced":["0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2024-27315"},{"ecosystem":"PyPI","fixed":["3.0.4","3.1.1"],"introduced":["0","3.1.0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2026-1181"},{"ecosystem":"PyPI","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-h7r6-8qmm-hj5r"},{"ecosystem":"PyPI","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-h7r6-8qmm-hj5r"},{"ecosystem":"PyPI","fixed":["3.1.1"],"introduced":["3.1.0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-h7r6-8qmm-hj5r"},{"ecosystem":"PyPI","fixed":["3.1.1"],"introduced":["3.1.0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-h7r6-8qmm-hj5r"}],"prev":{"headline":"Stored XSS Vulnerability","id":"CVE-2024-27314"},"products":["Apache Superset"],"published":"2024-02-28","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can trigger database errors via crafted SQL in alerts, potentially exposing sensitive data in error logs.","url":"https://insights.sbomify.com/CVE-2024-27315/"}