# CVE-2024-27319: Onnx Out-of-bounds Read vulnerability

> An out-of-bounds read in ONNX allows attackers to cause denial of service or disclose sensitive memory contents via crafted models.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** AZL-34465, AZL-35148, GHSA-h8wv-9h96-m4hr, PYSEC-2024-223

## What is CVE-2024-27319?

CVE-2024-27319 is a medium-severity memory corruption vulnerability in Fedoraproject Fedora, published on 23 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2024-27319?

3 open source packages ship an affected version, including onnx. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `onnx` | PyPI | All versions | 1.16.0 |
| `onnx` | PyPI | All versions | 1.16.0 |
| `onnx` | PyPI | All versions | 1.16.0 |

Products: Fedoraproject Fedora, Linuxfoundation Onnx.

## How do I fix CVE-2024-27319?

Upgrade onnx to 1.16.0 or later.

## Is CVE-2024-27319 being exploited?

There is no known exploitation of CVE-2024-27319 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27319 and fix it if it is affected.

What it is: CVE-2024-27319 is a medium-severity memory corruption vulnerability in Fedoraproject Fedora, published on 23 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-27319 in the wild and no public exploit code.

Affected packages and fixed versions:
- onnx (PyPI): affected all versions; fixed in 1.16.0
- onnx (PyPI): affected all versions; fixed in 1.16.0
- onnx (PyPI): affected all versions; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27319/ (Markdown: https://insights.sbomify.com/CVE-2024-27319/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27319
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27319
- OSV: https://osv.dev/vulnerability/CVE-2024-27319

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27319/
Summaries are generated and may contain mistakes; the official description above is the record.
