# CVE-2024-27347: Apache HugeGraph-Hubble: SSRF in Hubble connection page


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Apr 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-77x4-55q7-4vmj

## What is CVE-2024-27347?

CVE-2024-27347 is a medium-severity vulnerability in Apache HugeGraph-Hubble, published on 22 Apr 2024. 

### Official description

Server-Side Request Forgery (SSRF) vulnerability in Apache HugeGraph-Hubble.This issue affects Apache HugeGraph-Hubble: from 1.0.0 before 1.3.0.

Users are recommended to upgrade to version 1.3.0, which fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-27347?

2 open source packages ship an affected version, including org.apache.hugegraph:hugegraph-hubble. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hugegraph:hugegraph-hubble` | Maven | From 1.0.0 | 1.3.0 |
| `org.apache.hugegraph:hugegraph-hubble` | Maven | From 1.0.0 | 1.3.0 |

Products: Apache Hugegraph-Hubble.

## How do I fix CVE-2024-27347?

Upgrade org.apache.hugegraph:hugegraph-hubble to 1.3.0 or later.

## Is CVE-2024-27347 being exploited?

There is no known exploitation of CVE-2024-27347 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27347 and fix it if it is affected.

What it is: CVE-2024-27347 is a medium-severity vulnerability in Apache HugeGraph-Hubble, published on 22 Apr 2024. 
Exploitation: There is no known exploitation of CVE-2024-27347 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hugegraph:hugegraph-hubble (Maven): affected from 1.0.0; fixed in 1.3.0
- org.apache.hugegraph:hugegraph-hubble (Maven): affected from 1.0.0; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27347/ (Markdown: https://insights.sbomify.com/CVE-2024-27347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27347
- OSV: https://osv.dev/vulnerability/CVE-2024-27347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27347/
Summaries are generated and may contain mistakes; the official description above is the record.
