# CVE-2024-27348: Apache HugeGraph-Server Improper Access Control

> Attackers can execute arbitrary commands via Gremlin queries in Apache HugeGraph-Server, requiring authentication to be enabled for mitigation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 18 Sep 2024 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2024
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-29rc-vq7f-x335

## What is CVE-2024-27348?

CVE-2024-27348 is a critical code injection vulnerability in Apache HugeGraph-Server, published on 22 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RCE-Remote Command Execution vulnerability in Apache HugeGraph-Server.This issue affects Apache HugeGraph-Server: from 1.0.0 before 1.3.0 in Java8 & Java11

Users are recommended to upgrade to version 1.3.0 with Java11 & enable the Auth system, which fixes the issue.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-27348?

4 open source packages ship an affected version, including org.apache.hugegraph:hugegraph-api and org.apache.hugegraph:hugegraph-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hugegraph:hugegraph-api` | Maven | From 1.0.0 | 1.3.0 |
| `org.apache.hugegraph:hugegraph-api` | Maven | From 1.0.0 | 1.3.0 |
| `org.apache.hugegraph:hugegraph-core` | Maven | From 1.0.0 | 1.3.0 |
| `org.apache.hugegraph:hugegraph-core` | Maven | From 1.0.0 | 1.3.0 |

Products: Apache Hugegraph.

## How do I fix CVE-2024-27348?

Upgrade org.apache.hugegraph:hugegraph-api to 1.3.0 or later. US federal agencies must fix it by 9 Oct 2024.

## Is CVE-2024-27348 being exploited?

Yes. Attackers have exploited CVE-2024-27348 in the wild since at least 18 Sep 2024.

Public exploit code:

- Apache HugeGraph Server RCE Scanner ( CVE-2024-27348 ) (github_poc): https://github.com/Zeyad-Azima/CVE-2024-27348
- Apache HugeGraph Server Unauthenticated RCE - CVE-2024-27348 Proof of concept Exploit   (github_poc): https://github.com/kljunowsky/CVE-2024-27348
- https://github.com/jakabakos/CVE-2024-27348-Apache-HugeGraph-RCE (github_poc): https://github.com/jakabakos/CVE-2024-27348-Apache-HugeGraph-RCE
-  CVE-2024-27348 Exploitation Toolkit: Complete RCE exploit for Apache Huge-Graph-Server vulnerability. (github_poc): https://github.com/wqfh/CVE-2024-27348
- https://github.com/akelaqe/CVE-2024-27348-HugeGraph-RCE (github_poc): https://github.com/akelaqe/CVE-2024-27348-HugeGraph-RCE
- Apache HugeGraph Gremlin RCE (metasploit)

## Other vulnerabilities in Apache HugeGraph-Server

- [CVE-2024-43441](https://insights.sbomify.com/CVE-2024-43441/): Apache HugeGraph-Server: Fixed JWT Token(Secret) (critical 9.8)
- [CVE-2024-27349](https://insights.sbomify.com/CVE-2024-27349/): Apache HugeGraph-Server: Bypass whitelist in Auth mode (critical 9.1)
- [CVE-2025-26866](https://insights.sbomify.com/CVE-2025-26866/): Apache HugeGraph-Server: RAFT and deserialization vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27348 and fix it if it is affected.

What it is: CVE-2024-27348 is a critical code injection vulnerability in Apache HugeGraph-Server, published on 22 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2024-27348 in the wild since at least 18 Sep 2024.

Affected packages and fixed versions:
- org.apache.hugegraph:hugegraph-api (Maven): affected from 1.0.0; fixed in 1.3.0
- org.apache.hugegraph:hugegraph-api (Maven): affected from 1.0.0; fixed in 1.3.0
- org.apache.hugegraph:hugegraph-core (Maven): affected from 1.0.0; fixed in 1.3.0
- org.apache.hugegraph:hugegraph-core (Maven): affected from 1.0.0; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27348/ (Markdown: https://insights.sbomify.com/CVE-2024-27348/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27348
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27348
- OSV: https://osv.dev/vulnerability/CVE-2024-27348

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27348/
Summaries are generated and may contain mistakes; the official description above is the record.
