# CVE-2024-27349: Apache HugeGraph-Server: Bypass whitelist in Auth mode

> Attackers can bypass authentication whitelists in Apache HugeGraph-Server when auth mode is enabled, allowing unauthorized access.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2024
- **Updated:** 21 Aug 2025
- **Also known as:** GHSA-6mgp-p75r-vhjm

## What is CVE-2024-27349?

CVE-2024-27349 is a critical authentication bypass vulnerability in Apache HugeGraph-Server, published on 22 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authentication Bypass by Spoofing vulnerability in Apache HugeGraph-Server.This issue affects Apache HugeGraph-Server: from 1.0.0 before 1.3.0.

Users are recommended to upgrade to version 1.3.0, which fixes the issue.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2024-27349?

2 open source packages ship an affected version, including org.apache.hugegraph:hugegraph-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hugegraph:hugegraph-api` | Maven | From 1.0.0 | 1.3.0 |
| `org.apache.hugegraph:hugegraph-api` | Maven | From 1.0.0 | 1.3.0 |

Products: Apache Hugegraph.

## How do I fix CVE-2024-27349?

Upgrade org.apache.hugegraph:hugegraph-api to 1.3.0 or later.

## Is CVE-2024-27349 being exploited?

There is no known exploitation of CVE-2024-27349 in the wild and no public exploit code.

## Other vulnerabilities in Apache HugeGraph-Server

- [CVE-2024-27348](https://insights.sbomify.com/CVE-2024-27348/): Apache HugeGraph-Server Improper Access Control (critical 9.8, exploited in the wild)
- [CVE-2024-43441](https://insights.sbomify.com/CVE-2024-43441/): Apache HugeGraph-Server: Fixed JWT Token(Secret) (critical 9.8)
- [CVE-2025-26866](https://insights.sbomify.com/CVE-2025-26866/): Apache HugeGraph-Server: RAFT and deserialization vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27349 and fix it if it is affected.

What it is: CVE-2024-27349 is a critical authentication bypass vulnerability in Apache HugeGraph-Server, published on 22 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27349 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hugegraph:hugegraph-api (Maven): affected from 1.0.0; fixed in 1.3.0
- org.apache.hugegraph:hugegraph-api (Maven): affected from 1.0.0; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27349/ (Markdown: https://insights.sbomify.com/CVE-2024-27349/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27349
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27349
- OSV: https://osv.dev/vulnerability/CVE-2024-27349

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27349/
Summaries are generated and may contain mistakes; the official description above is the record.
