CVE-2024-27355 phpseclib guardrails needed on OID length
Attackers can cause CPU exhaustion and denial of service by providing malicious ASN.1 object identifiers in certificates processed by phpseclib.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-27355?
CVE-2024-27355 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. When processing the ASN.1 object identifier of a certificate, a sub identifier may be provided that leads to a denial of service (CPU consumption for decodeOID).
Weakness: CWE-400
Which versions are affected by CVE-2024-27355?
6 open source packages ship an affected version, including phpseclib/phpseclib. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
phpseclib/phpseclib Packagist | From 0.1.1 | 1.0.23 |
phpseclib/phpseclib Packagist | From 0.1.1 | 1.0.23 |
phpseclib/phpseclib Packagist | From 2.0.0 | 2.0.47 |
phpseclib/phpseclib Packagist | From 2.0.0 | 2.0.47 |
phpseclib/phpseclib Packagist | From 3.0.0 | 3.0.36 |
phpseclib/phpseclib Packagist | From 3.0.0 | 3.0.36 |
Linux distribution packages (1)
cacti openSUSE:Tumbleweed | All versions | 1.2.30+git457.e55c2aea-1.1 |
Products include Debian Debian Linux, Phpseclib Phpseclib.
How do I fix CVE-2024-27355?
Upgrade phpseclib/phpseclib to a fixed version for your release line: 1.0.23, 2.0.47 or 3.0.36.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-27355 being exploited?
There is no known exploitation of CVE-2024-27355 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2024-27355, GHSA-f2qx-66wf-wvvx, UBUNTU-CVE-2024-27355, openSUSE-SU-2026:10920-1.