{"answers":{"affected":"6 open source packages ship an affected version, including phpseclib/phpseclib. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-27355 in the wild and no public exploit code.","fix":"Upgrade phpseclib/phpseclib to a fixed version for your release line: 1.0.23, 2.0.47 or 3.0.36.","what":"CVE-2024-27355 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27355 and fix it if it is affected.\n\nWhat it is: CVE-2024-27355 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-27355 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpseclib/phpseclib (Packagist): affected from 0.1.1; fixed in 1.0.23\n- phpseclib/phpseclib (Packagist): affected from 0.1.1; fixed in 1.0.23\n- phpseclib/phpseclib (Packagist): affected from 2.0.0; fixed in 2.0.47\n- phpseclib/phpseclib (Packagist): affected from 2.0.0; fixed in 2.0.47\n- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.36\n- phpseclib/phpseclib (Packagist): affected from 3.0.0; fixed in 3.0.36\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27355/ (Markdown: https://insights.sbomify.com/CVE-2024-27355/index.md)","id":"CVE-2024-27355","markdown":"https://insights.sbomify.com/CVE-2024-27355/index.md","name":"CVE-2024-27355","record":{"aliases":["DEBIAN-CVE-2024-27355","GHSA-f2qx-66wf-wvvx","UBUNTU-CVE-2024-27355","openSUSE-SU-2026:10920-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP cryptography library","requires_auth":"none","summary":"Attackers can cause CPU exhaustion and denial of service by providing malicious ASN.1 object identifiers in certificates processed by phpseclib.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"phpseclib","vendor":"phpseclib"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. When processing the ASN.1 object identifier of a certificate, a sub identifier may be provided that leads to a denial of service (CPU consumption for decodeOID).","ecosystems":["Packagist","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpseclib guardrails needed on OID length","id":"CVE-2024-27355","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"denial_of_service","year":"2024"},"n_packages":7,"n_references":4,"next":{"headline":"Information disclosure in n/a","id":"CVE-2024-27356"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.23"],"introduced":["0.1.1"],"last_affected":[],"package":"phpseclib/phpseclib","purl":null,"source":"GHSA-f2qx-66wf-wvvx"},{"ecosystem":"Packagist","fixed":["1.0.23"],"introduced":["0.1.1"],"last_affected":[],"package":"phpseclib/phpseclib","purl":"pkg:composer/phpseclib/phpseclib","source":"GHSA-f2qx-66wf-wvvx"},{"ecosystem":"Packagist","fixed":["2.0.47"],"introduced":["2.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":null,"source":"GHSA-f2qx-66wf-wvvx"},{"ecosystem":"Packagist","fixed":["2.0.47"],"introduced":["2.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":"pkg:composer/phpseclib/phpseclib","source":"GHSA-f2qx-66wf-wvvx"},{"ecosystem":"Packagist","fixed":["3.0.36"],"introduced":["3.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":null,"source":"GHSA-f2qx-66wf-wvvx"},{"ecosystem":"Packagist","fixed":["3.0.36"],"introduced":["3.0.0"],"last_affected":[],"package":"phpseclib/phpseclib","purl":"pkg:composer/phpseclib/phpseclib","source":"GHSA-f2qx-66wf-wvvx"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.2.30+git457.e55c2aea-1.1"],"introduced":["0"],"last_affected":[],"package":"cacti","purl":"pkg:rpm/opensuse/cacti\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10920-1"}],"prev":{"headline":"phpseclib: guardrails needed on isPrime and randomPrime","id":"CVE-2024-27354"},"products":["n/a"],"published":"2024-03-01","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-13","vendors":["n/a"]},"summary":"Attackers can cause CPU exhaustion and denial of service by providing malicious ASN.1 object identifiers in certificates processed by phpseclib.","url":"https://insights.sbomify.com/CVE-2024-27355/"}