CVE-2024-2743 Incorrect Authorization in GitLab
An attacker can modify on-demand DAST scans and leak variables without proper permissions in GitLab Enterprise Edition.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-2743?
CVE-2024-2743 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 12 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in GitLab-EE starting with version 13.3 before 17.1.7, 17.2 before 17.2.5, and 17.3 before 17.3.2 that would allow an attacker to modify an on-demand DAST scan without permissions and leak variables.
Weakness: CWE-863
Which versions are affected by CVE-2024-2743?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.3.0 | 17.1.7, 17.2.5, 17.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-2743?
Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-2743 being exploited?
There is no known exploitation of CVE-2024-2743 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-2743, GHSA-254h-gvgq-x2xg.