# CVE-2024-27439: Apache Wicket: Possible bypass of CSRF protection

> Attackers can bypass CSRF protection in Apache Wicket due to flawed fetch metadata header evaluation, requiring an upgrade to secure the application.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-8vvp-525h-cxf9

## What is CVE-2024-27439?

CVE-2024-27439 is a medium-severity vulnerability in Apache Wicket, published on 19 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An error in the evaluation of the fetch metadata headers could allow a bypass of the CSRF protection in Apache Wicket.
This issue affects Apache Wicket: from 9.1.0 through 9.16.0, and the milestone releases for the 10.0 series.
Apache Wicket 8.x does not support CSRF protection via the fetch metadata headers and as such is not affected.

Users are recommended to upgrade to version 9.17.0 or 10.0.0, which fixes the issue.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-27439?

4 open source packages ship an affected version, including org.apache.wicket:wicket. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.wicket:wicket` | Maven | From 10.0.0-M1 | 10.0.0 |
| `org.apache.wicket:wicket` | Maven | From 10.0.0-M1 | 10.0.0 |
| `org.apache.wicket:wicket` | Maven | From 9.1.0 | 9.17.0 |
| `org.apache.wicket:wicket` | Maven | From 9.1.0 | 9.17.0 |

Products: Apache Wicket.

## How do I fix CVE-2024-27439?

Upgrade org.apache.wicket:wicket to a fixed version for your release line: 10.0.0 or 9.17.0.

## Is CVE-2024-27439 being exploited?

There is no known exploitation of CVE-2024-27439 in the wild and no public exploit code.

## Other vulnerabilities in Apache Wicket

- [CVE-2024-36522](https://insights.sbomify.com/CVE-2024-36522/): Apache Wicket: Remote code execution via XSLT injection (critical 9.8)
- [CVE-2026-40010](https://insights.sbomify.com/CVE-2026-40010/): Apache Wicket: possible session fixation using AuthenticatedWebSession (critical 9.1)
- [CVE-2016-6793](https://insights.sbomify.com/CVE-2016-6793/): Deserialization in n/a (critical 9.1)
- [CVE-2016-6806](https://insights.sbomify.com/CVE-2016-6806/): Apache Wicket vulnerable to CSRF attacks (high 8.8)
- [CVE-2026-71257](https://insights.sbomify.com/CVE-2026-71257/): Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27439 and fix it if it is affected.

What it is: CVE-2024-27439 is a medium-severity vulnerability in Apache Wicket, published on 19 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27439 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.wicket:wicket (Maven): affected from 10.0.0-M1; fixed in 10.0.0
- org.apache.wicket:wicket (Maven): affected from 10.0.0-M1; fixed in 10.0.0
- org.apache.wicket:wicket (Maven): affected from 9.1.0; fixed in 9.17.0
- org.apache.wicket:wicket (Maven): affected from 9.1.0; fixed in 9.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27439/ (Markdown: https://insights.sbomify.com/CVE-2024-27439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27439
- OSV: https://osv.dev/vulnerability/CVE-2024-27439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27439/
Summaries are generated and may contain mistakes; the official description above is the record.
