# CVE-2024-27444: LangChain Experimental vulnerable to arbitrary code execution

> Attackers can execute arbitrary code in LangChain Experimental by bypassing previous security fixes using Python dunder attributes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2024
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-v8vj-cv27-hjv8, PYSEC-2026-375

## What is CVE-2024-27444?

CVE-2024-27444 is a critical code injection vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

langchain_experimental (aka LangChain Experimental) in LangChain before 0.1.8 allows an attacker to bypass the CVE-2023-44467 fix and execute arbitrary code via the __import__, __subclasses__, __builtins__, __globals__, __getattribute__, __bases__, __mro__, or __base__ attribute in Python code. These are not prohibited by pal_chain/base.py.

Weakness: CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2024-27444?

3 open source packages ship an affected version, including langchain-experimental. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-experimental` | PyPI | All versions | 0.0.52 |
| `langchain-experimental` | PyPI | All versions | 0.0.52 |
| `langchain-experimental` | PyPI | All versions | 0.0.52 |

Products: Langchain Langchain-Experimental.

## How do I fix CVE-2024-27444?

Upgrade langchain-experimental to 0.0.52 or later.

## Is CVE-2024-27444 being exploited?

There is no known exploitation of CVE-2024-27444 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-46946](https://insights.sbomify.com/CVE-2024-46946/): LangChain Experimental Eval Injection vulnerability (critical 9.8)
- [CVE-2024-21513](https://insights.sbomify.com/CVE-2024-21513/): langchain-experimental vulnerable to Arbitrary Code Execution (high 8.5)
- [CVE-2024-38459](https://insights.sbomify.com/CVE-2024-38459/): langchain_experimental Code Execution via Python REPL access (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27444 and fix it if it is affected.

What it is: CVE-2024-27444 is a critical code injection vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27444 in the wild and no public exploit code.

Affected packages and fixed versions:
- langchain-experimental (PyPI): affected all versions; fixed in 0.0.52
- langchain-experimental (PyPI): affected all versions; fixed in 0.0.52
- langchain-experimental (PyPI): affected all versions; fixed in 0.0.52

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27444/ (Markdown: https://insights.sbomify.com/CVE-2024-27444/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27444
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27444
- OSV: https://osv.dev/vulnerability/CVE-2024-27444

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27444/
Summaries are generated and may contain mistakes; the official description above is the record.
