{"answers":{"affected":"2 open source packages ship an affected version, including maildev.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27448 exists.","fix":"No fix has been published for CVE-2024-27448 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-27448 is a critical code injection vulnerability in n/a, published on 5 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27448 and fix it if it is affected.\n\nWhat it is: CVE-2024-27448 is a critical code injection vulnerability in n/a, published on 5 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27448 exists.\n\nAffected packages and fixed versions:\n- maildev (npm): affected from 2.0.0-beta1 up to 2.1.0; no fix listed\n- maildev (npm): affected from 2.0.0-beta1 up to 2.1.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27448/ (Markdown: https://insights.sbomify.com/CVE-2024-27448/index.md)","id":"CVE-2024-27448","markdown":"https://insights.sbomify.com/CVE-2024-27448/index.md","name":"CVE-2024-27448","record":{"aliases":["GHSA-vc6q-ccj9-9r89"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MailDev email tool","requires_auth":"none","summary":"Attackers can execute arbitrary code by sending crafted emails, affecting MailDev users who should upgrade immediately.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"MailDev 2 through 2.1.0 allows Remote Code Execution via a crafted Content-ID header for an e-mail attachment, leading to lib/mailserver.js writing arbitrary code into the routes.js file.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"MailDev Remote Code Execution","id":"CVE-2024-27448","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2024-27453"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["2.0.0-beta1"],"last_affected":["2.1.0"],"package":"maildev","purl":null,"source":"GHSA-vc6q-ccj9-9r89"},{"ecosystem":"npm","fixed":[],"introduced":["2.0.0-beta1"],"last_affected":["2.1.0"],"package":"maildev","purl":"pkg:npm/maildev","source":"GHSA-vc6q-ccj9-9r89"}],"prev":{"headline":"pretix mishandles file validation","id":"CVE-2024-27447"},"products":["n/a"],"published":"2024-04-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-13","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by sending crafted emails, affecting MailDev users who should upgrade immediately.","url":"https://insights.sbomify.com/CVE-2024-27448/"}