{"answers":{"affected":"3 open source packages ship an affected version, including orjson. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-27454 in the wild and no public exploit code.","fix":"Upgrade orjson to 3.9.15 or later.","what":"CVE-2024-27454 is a high-severity denial of service vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27454 and fix it if it is affected.\n\nWhat it is: CVE-2024-27454 is a high-severity denial of service vulnerability in n/a, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-27454 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- orjson (PyPI): affected all versions; fixed in 3.9.15\n- orjson (PyPI): affected all versions; fixed in 3.9.15\n- orjson (PyPI): affected all versions; fixed in 3.9.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27454/ (Markdown: https://insights.sbomify.com/CVE-2024-27454/index.md)","id":"CVE-2024-27454","markdown":"https://insights.sbomify.com/CVE-2024-27454/index.md","name":"CVE-2024-27454","record":{"aliases":["CLSA-2026-1787140595","DEBIAN-CVE-2024-27454","ECHO-858e-faea-85ef","GHSA-pwr2-4v36-6qpr","PYSEC-2024-40","ROOT-APP-PYPI-CVE-2024-27454","openSUSE-SU-2024:13735-1","openSUSE-SU-2024:13780-1","openSUSE-SU-2026:12024-1","openSUSE-SU-2026:12033-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python JSON library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using orjson by submitting deeply nested JSON documents that trigger excessive recursion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"orjson","vendor":"ijl"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AC:L/AV:N/A:H/C:N/I:N/PR:N/S:U/UI:N","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"orjson.loads in orjson before 3.9.15 does not limit recursion for deeply nested JSON documents.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"orjson does not limit recursion for deeply nested JSON documents","id":"CVE-2024-27454","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":5,"n_references":4,"next":{"headline":"Information disclosure in n/a","id":"CVE-2024-27455"},"packages":[{"ecosystem":"PyPI","fixed":["3.9.15"],"introduced":["0"],"last_affected":[],"package":"orjson","purl":null,"source":"GHSA-pwr2-4v36-6qpr"},{"ecosystem":"PyPI","fixed":["3.9.15"],"introduced":["0"],"last_affected":[],"package":"orjson","purl":"pkg:pypi/orjson","source":"GHSA-pwr2-4v36-6qpr"},{"ecosystem":"PyPI","fixed":["3.9.15"],"introduced":["0"],"last_affected":[],"package":"orjson","purl":"pkg:pypi/orjson","source":"PYSEC-2024-40"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.11.9-1.4"],"introduced":["0"],"last_affected":[],"package":"python-orjson","purl":"pkg:rpm/opensuse/python-orjson\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12024-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.23-1.4"],"introduced":["0"],"last_affected":[],"package":"python-python-rapidjson","purl":"pkg:rpm/opensuse/python-python-rapidjson\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12033-1"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2024-27453"},"products":["n/a"],"published":"2024-02-26","related":[{"cvss_score":7.5,"headline":"orjson does not limit recursion for deeply nested JSON documents","id":"CVE-2025-67221","kev_date_added":null,"published":"2026-01-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can cause denial of service in applications using orjson by submitting deeply nested JSON documents that trigger excessive recursion.","url":"https://insights.sbomify.com/CVE-2024-27454/"}