CVE-2024-27499 Bagist Cross-site Scripting vulnerability

Medium 6.5 Published Updated

Attacker can execute arbitrary scripts via malicious PNG upload in product reviews, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-27499?

CVE-2024-27499 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Bagisto v1.5.1 is vulnerable for Cross site scripting(XSS) via png file upload vulnerability in product review option.

Weakness: CWE-79

Which versions are affected by CVE-2024-27499?

2 open source packages ship an affected version, including bagisto/bagisto. It affects 1 product.

PackageAffectedFixed in
bagisto/bagisto PackagistAll versions2.1.0
bagisto/bagisto PackagistAll versions2.1.0

Products include Webkul Bagisto.

How do I fix CVE-2024-27499?

Upgrade bagisto/bagisto to 2.1.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-27499 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27499 exists.

Sources

Also known as GHSA-w5mx-334j-6fwv.

Is CVE-2024-27499 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free