# CVE-2024-27516: livehelperchat Server-Side Template Injection

> Remote attackers can execute arbitrary code and read sensitive data via a Server-Side Template Injection flaw in the FAQ weight module.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-v4cp-2q7v-hg9q

## What is CVE-2024-27516?

CVE-2024-27516 is a critical code injection vulnerability in n/a, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Server-Side Template Injection (SSTI) vulnerability in livehelperchat before 4.34v, allows remote attackers to execute arbitrary code and obtain sensitive information via the search parameter in lhc_web/modules/lhfaq/faqweight.php.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2024-27516?

2 open source packages ship an affected version, including remdex/livehelperchat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `remdex/livehelperchat` | Packagist | All versions | 4.29 |
| `remdex/livehelperchat` | Packagist | All versions | 4.29 |

Products: Livehelperchat Live Helper Chat.

## How do I fix CVE-2024-27516?

Upgrade remdex/livehelperchat to 4.29 or later.

## Is CVE-2024-27516 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27516 exists.

## Other vulnerabilities in n/a

- [CVE-2022-0935](https://insights.sbomify.com/CVE-2022-0935/): Host Header injection in password Reset in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1234](https://insights.sbomify.com/CVE-2022-1234/): XSS in livehelperchat in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1191](https://insights.sbomify.com/CVE-2022-1191/): SSRF on index.php/cobrowse/proxycss/ in livehelperchat/livehelperchat (high 8.7)
- [CVE-2022-1213](https://insights.sbomify.com/CVE-2022-1213/): SSRF filter bypass port 80, 433 in livehelperchat/livehelperchat (high 7.7)
- [CVE-2022-1235](https://insights.sbomify.com/CVE-2022-1235/): Weak secrethash can be brute-forced in livehelperchat/livehelperchat (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27516 and fix it if it is affected.

What it is: CVE-2024-27516 is a critical code injection vulnerability in n/a, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27516 exists.

Affected packages and fixed versions:
- remdex/livehelperchat (Packagist): affected all versions; fixed in 4.29
- remdex/livehelperchat (Packagist): affected all versions; fixed in 4.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27516/ (Markdown: https://insights.sbomify.com/CVE-2024-27516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27516
- OSV: https://osv.dev/vulnerability/CVE-2024-27516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27516/
Summaries are generated and may contain mistakes; the official description above is the record.
