{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2757 exists.","fix":"Upgrade libphp to 8.3.5 or later.","what":"CVE-2024-2757 is a high-severity denial of service vulnerability in Php Php, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-2757 and fix it if it is affected.\n\nWhat it is: CVE-2024-2757 is a high-severity denial of service vulnerability in Php Php, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2757 exists.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected from 8.3.0; fixed in 8.3.5\n- php (Bitnami): affected from 8.3.0; fixed in 8.3.5\n- php-min (Bitnami): affected from 8.3.0; fixed in 8.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-2757/ (Markdown: https://insights.sbomify.com/CVE-2024-2757/index.md)","id":"CVE-2024-2757","markdown":"https://insights.sbomify.com/CVE-2024-2757/index.md","name":"CVE-2024-2757","record":{"aliases":["AZL-40055","BELL-CVE-2024-2757","BIT-libphp-2024-2757","BIT-php-2024-2757","BIT-php-min-2024-2757","CLEANSTART-2026-AE99282","GHSA-fjp9-9hwx-59fq","UBUNTU-CVE-2024-2757"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP core library","requires_auth":"none","summary":"Attackers can cause a denial of service by sending specific inputs to applications using the mb_encode_mimeheader function in PHP.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"In PHP 8.3.* before 8.3.5, function mb_encode_mimeheader() runs endlessly for some inputs that contain long strings of non-space characters followed by a space. This could lead to a potential DoS attack if a hostile user sends data to an application that uses this function.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PHP mb_encode_mimeheader runs endlessly for some inputs","id":"CVE-2024-2757","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"CVE-2024-2758","id":"CVE-2024-2758"},"packages":[{"ecosystem":"Bitnami","fixed":["8.3.5"],"introduced":["8.3.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2024-2757"},{"ecosystem":"Bitnami","fixed":["8.3.5"],"introduced":["8.3.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2024-2757"},{"ecosystem":"Bitnami","fixed":["8.3.5"],"introduced":["8.3.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2024-2757"}],"prev":{"headline":"__Host-/__Secure- cookie bypass due to partial CVE-2022-31629 fix","id":"CVE-2024-2756"},"products":["PHP"],"published":"2024-04-29","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["PHP Group"]},"summary":"Attackers can cause a denial of service by sending specific inputs to applications using the mb_encode_mimeheader function in PHP.","url":"https://insights.sbomify.com/CVE-2024-2757/"}