# CVE-2024-2757: PHP mb_encode_mimeheader runs endlessly for some inputs

> Attackers can cause a denial of service by sending specific inputs to applications using the mb_encode_mimeheader function in PHP.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2024
- **Updated:** 4 Nov 2025
- **Also known as:** AZL-40055, BELL-CVE-2024-2757, BIT-libphp-2024-2757, BIT-php-2024-2757, BIT-php-min-2024-2757, CLEANSTART-2026-AE99282, GHSA-fjp9-9hwx-59fq, UBUNTU-CVE-2024-2757

## What is CVE-2024-2757?

CVE-2024-2757 is a high-severity denial of service vulnerability in Php Php, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP 8.3.* before 8.3.5, function mb_encode_mimeheader() runs endlessly for some inputs that contain long strings of non-space characters followed by a space. This could lead to a potential DoS attack if a hostile user sends data to an application that uses this function.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-2757?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.3.0 | 8.3.5 |
| `php` | Bitnami | From 8.3.0 | 8.3.5 |
| `php-min` | Bitnami | From 8.3.0 | 8.3.5 |

Products: Php Php.

## How do I fix CVE-2024-2757?

Upgrade libphp to 8.3.5 or later.

## Is CVE-2024-2757 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2757 exists.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2757 and fix it if it is affected.

What it is: CVE-2024-2757 is a high-severity denial of service vulnerability in Php Php, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2757 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.3.0; fixed in 8.3.5
- php (Bitnami): affected from 8.3.0; fixed in 8.3.5
- php-min (Bitnami): affected from 8.3.0; fixed in 8.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2757/ (Markdown: https://insights.sbomify.com/CVE-2024-2757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2757
- OSV: https://osv.dev/vulnerability/CVE-2024-2757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2757/
Summaries are generated and may contain mistakes; the official description above is the record.
