{"answers":{"affected":"3 open source packages ship an affected version, including rpyc.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27758 exists.","fix":"Upgrade rpyc to 6.0.0 or later.","what":"CVE-2024-27758 is a high-severity code injection vulnerability in n/a, published on 12 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27758 and fix it if it is affected.\n\nWhat it is: CVE-2024-27758 is a high-severity code injection vulnerability in n/a, published on 12 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27758 exists.\n\nAffected packages and fixed versions:\n- rpyc (PyPI): affected all versions; fixed in 6.0.0\n- rpyc (PyPI): affected from 4.0.0; fixed in 6.0.0\n- rpyc (PyPI): affected from 4.0.0; fixed in 6.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27758/ (Markdown: https://insights.sbomify.com/CVE-2024-27758/index.md)","id":"CVE-2024-27758","markdown":"https://insights.sbomify.com/CVE-2024-27758/index.md","name":"CVE-2024-27758","record":{"aliases":["DEBIAN-CVE-2024-27758","GHSA-h5cg-53g7-gqjw","PYSEC-2024-44","UBUNTU-CVE-2024-27758","openSUSE-SU-2024:0082-1","openSUSE-SU-2024:13768-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python RPyC library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code by exploiting unsafe attribute access in RPyC server methods handling client netrefs.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"In RPyC before 6.0.0, when a server exposes a method that calls the attribute named __array__ for a client-provided netref (e.g., np.array(client_netref)), a remote attacker can craft a class that results in remote code execution.","ecosystems":["PyPI","SUSE:Package Hub 15 SP5","openSUSE:Leap 15.5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"RPyC's missing security check results in code execution when using numpy.array on the server-side.","id":"CVE-2024-27758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":7,"n_references":2,"next":{"headline":"XPixelGroup BasicSR Command Injection","id":"CVE-2024-27763"},"packages":[{"ecosystem":"PyPI","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"rpyc","purl":"pkg:pypi/rpyc","source":"PYSEC-2024-44"},{"ecosystem":"PyPI","fixed":["6.0.0"],"introduced":["4.0.0"],"last_affected":[],"package":"rpyc","purl":null,"source":"GHSA-h5cg-53g7-gqjw"},{"ecosystem":"PyPI","fixed":["6.0.0"],"introduced":["4.0.0"],"last_affected":[],"package":"rpyc","purl":"pkg:pypi/rpyc","source":"GHSA-h5cg-53g7-gqjw"},{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["4.1.5-bp155.3.3.1"],"introduced":["0"],"last_affected":[],"package":"python-rpyc","purl":"pkg:rpm/suse/python-rpyc\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0082-1"},{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["4.1.5-bp155.3.3.1"],"introduced":["0"],"last_affected":[],"package":"python-rpyc-test","purl":"pkg:rpm/suse/python-rpyc-test\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0082-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["4.1.5-bp155.3.3.1"],"introduced":["0"],"last_affected":[],"package":"python-rpyc","purl":"pkg:rpm/opensuse/python-rpyc\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0082-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["4.1.5-bp155.3.3.1"],"introduced":["0"],"last_affected":[],"package":"python-rpyc-test","purl":"pkg:rpm/opensuse/python-rpyc-test\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0082-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-27757"},"products":["n/a"],"published":"2024-03-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code by exploiting unsafe attribute access in RPyC server methods handling client netrefs.","url":"https://insights.sbomify.com/CVE-2024-27758/"}