# CVE-2024-27758: RPyC's missing security check results in code execution when using numpy.array on the server-side.

> Remote attackers can execute arbitrary code by exploiting unsafe attribute access in RPyC server methods handling client netrefs.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-27758, GHSA-h5cg-53g7-gqjw, PYSEC-2024-44, UBUNTU-CVE-2024-27758, openSUSE-SU-2024:0082-1, openSUSE-SU-2024:13768-1

## What is CVE-2024-27758?

CVE-2024-27758 is a high-severity code injection vulnerability in n/a, published on 12 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In RPyC before 6.0.0, when a server exposes a method that calls the attribute named __array__ for a client-provided netref (e.g., np.array(client_netref)), a remote attacker can craft a class that results in remote code execution.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2024-27758?

3 open source packages ship an affected version, including rpyc.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rpyc` | PyPI | All versions | 6.0.0 |
| `rpyc` | PyPI | From 4.0.0 | 6.0.0 |
| `rpyc` | PyPI | From 4.0.0 | 6.0.0 |
| `python-rpyc` | SUSE:Package Hub 15 SP5 | All versions | 4.1.5-bp155.3.3.1 |
| `python-rpyc-test` | SUSE:Package Hub 15 SP5 | All versions | 4.1.5-bp155.3.3.1 |
| `python-rpyc` | openSUSE:Leap 15.5 | All versions | 4.1.5-bp155.3.3.1 |
| `python-rpyc-test` | openSUSE:Leap 15.5 | All versions | 4.1.5-bp155.3.3.1 |

## How do I fix CVE-2024-27758?

Upgrade rpyc to 6.0.0 or later.

## Is CVE-2024-27758 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27758 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27758 and fix it if it is affected.

What it is: CVE-2024-27758 is a high-severity code injection vulnerability in n/a, published on 12 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27758 exists.

Affected packages and fixed versions:
- rpyc (PyPI): affected all versions; fixed in 6.0.0
- rpyc (PyPI): affected from 4.0.0; fixed in 6.0.0
- rpyc (PyPI): affected from 4.0.0; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27758/ (Markdown: https://insights.sbomify.com/CVE-2024-27758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27758
- OSV: https://osv.dev/vulnerability/CVE-2024-27758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27758/
Summaries are generated and may contain mistakes; the official description above is the record.
