{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-27906 in the wild and no public exploit code.","fix":"Upgrade apache-airflow to 2.8.2 or later.","what":"CVE-2024-27906 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 29 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27906 and fix it if it is affected.\n\nWhat it is: CVE-2024-27906 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 29 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-27906 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow (PyPI): affected all versions; fixed in 2.8.2\n- apache-airflow (PyPI): affected all versions; fixed in 2.8.2\n- apache-airflow (PyPI): affected all versions; fixed in 2.8.2\n- airflow (Bitnami): affected all versions; fixed in 2.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27906/ (Markdown: https://insights.sbomify.com/CVE-2024-27906/index.md)","id":"CVE-2024-27906","markdown":"https://insights.sbomify.com/CVE-2024-27906/index.md","name":"CVE-2024-27906","record":{"aliases":["BIT-airflow-2024-27906","ECHO-a030-1ce9-bbe7","GHSA-6v6w-h8m6-7mv2","PYSEC-2024-245"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Apache Airflow","requires_auth":"none","summary":"Authenticated users can view DAG code and import errors for DAGs they lack permission to access via the API or UI.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow","vendor":"apache"}],"cvss":{"score":5.9,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI.\n\nUsers of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow: Dag Code and Import Error Permissions Ignored","id":"CVE-2024-27906","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:airflow","products":["apache:airflow"],"type":"missing_authorization","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"Memory corruption in Simcenter Femap","id":"CVE-2024-27907"},"packages":[{"ecosystem":"Bitnami","fixed":["2.8.2"],"introduced":["0"],"last_affected":[],"package":"airflow","purl":"pkg:bitnami/airflow","source":"BIT-airflow-2024-27906"},{"ecosystem":"PyPI","fixed":["2.8.2"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":null,"source":"GHSA-6v6w-h8m6-7mv2"},{"ecosystem":"PyPI","fixed":["2.8.2"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"GHSA-6v6w-h8m6-7mv2"},{"ecosystem":"PyPI","fixed":["2.8.2"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2024-245"}],"prev":{"headline":"Apache Aurora: padding oracle can allow construction an authentication cookie","id":"CVE-2024-27905"},"products":["Apache Airflow"],"published":"2024-02-29","related":[{"cvss_score":9.8,"headline":"Apache Airflow's Experimental API Authentication Bypass","id":"CVE-2020-13927","kev_date_added":"2022-01-18","published":"2020-11-10"},{"cvss_score":8.8,"headline":"Apache Airflow Command Injection","id":"CVE-2020-11978","kev_date_added":"2022-01-18","published":"2020-07-16"},{"cvss_score":9.8,"headline":"Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()","id":"CVE-2026-33264","kev_date_added":null,"published":"2026-07-07"},{"cvss_score":9.8,"headline":"Apache Airflow: Privilege escalation using airflow logs","id":"CVE-2023-25754","kev_date_added":null,"published":"2023-05-08"},{"cvss_score":9.8,"headline":"Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow","id":"CVE-2023-22884","kev_date_added":null,"published":"2023-01-21"},{"cvss_score":9.8,"headline":"Apache Airflow Pinot provider allowed Command Injection","id":"CVE-2022-38649","kev_date_added":null,"published":"2022-11-22"},{"cvss_score":9.8,"headline":"Apache Airlfow Pig Provider RCE","id":"CVE-2022-40189","kev_date_added":null,"published":"2022-11-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-06","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can view DAG code and import errors for DAGs they lack permission to access via the API or UI.","url":"https://insights.sbomify.com/CVE-2024-27906/"}