# CVE-2024-27906: Apache Airflow: Dag Code and Import Error Permissions Ignored

> Authenticated users can view DAG code and import errors for DAGs they lack permission to access via the API or UI.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Feb 2024
- **Updated:** 6 May 2025
- **Also known as:** BIT-airflow-2024-27906, ECHO-a030-1ce9-bbe7, GHSA-6v6w-h8m6-7mv2, PYSEC-2024-245

## What is CVE-2024-27906?

CVE-2024-27906 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 29 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI.

Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-27906?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.8.2 |
| `apache-airflow` | PyPI | All versions | 2.8.2 |
| `apache-airflow` | PyPI | All versions | 2.8.2 |
| `airflow` | Bitnami | All versions | 2.8.2 |

Products: Apache Airflow.

## How do I fix CVE-2024-27906?

Upgrade apache-airflow to 2.8.2 or later.

## Is CVE-2024-27906 being exploited?

There is no known exploitation of CVE-2024-27906 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27906 and fix it if it is affected.

What it is: CVE-2024-27906 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 29 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27906 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.8.2
- apache-airflow (PyPI): affected all versions; fixed in 2.8.2
- apache-airflow (PyPI): affected all versions; fixed in 2.8.2
- airflow (Bitnami): affected all versions; fixed in 2.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27906/ (Markdown: https://insights.sbomify.com/CVE-2024-27906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27906
- OSV: https://osv.dev/vulnerability/CVE-2024-27906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27906/
Summaries are generated and may contain mistakes; the official description above is the record.
