# CVE-2024-27915: Sulu grants access to pages regardless of role permissions

> Attackers can access restricted pages in Sulu CMS when security systems are enabled, bypassing role-based permission checks.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 16 Apr 2025
- **Also known as:** GHSA-jr83-m233-gg6p

## What is CVE-2024-27915?

CVE-2024-27915 is a medium-severity missing authorization vulnerability in sulu, published on 6 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sulu is a PHP content management system. Starting in verson 2.2.0 and prior to version 2.4.17 and 2.5.13, access to pages is granted regardless of role permissions for webspaces which have a security system configured and permission check enabled. Webspaces without do not have this issue. The problem is patched in versions 2.4.17 and 2.5.13. Some workarounds are available. One may apply the patch to `vendor/symfony/security-http/HttpUtils.php` manually or avoid installing `symfony/security-http` versions greater equal than `v5.4.30` or `v6.3.6`.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-27915?

4 open source packages ship an affected version, including sulu/sulu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sulu/sulu` | Packagist | From 2.2.0 | 2.4.17 |
| `sulu/sulu` | Packagist | From 2.2.0 | 2.4.17 |
| `sulu/sulu` | Packagist | From 2.5.0-alpha1 | 2.5.13 |
| `sulu/sulu` | Packagist | From 2.5.0-alpha1 | 2.5.13 |

Products: Sulu Sulu.

## How do I fix CVE-2024-27915?

Upgrade sulu/sulu to a fixed version for your release line: 2.4.17 or 2.5.13.

## Is CVE-2024-27915 being exploited?

There is no known exploitation of CVE-2024-27915 in the wild and no public exploit code.

## Other vulnerabilities in sulu

- [CVE-2021-43836](https://insights.sbomify.com/CVE-2021-43836/): PHP file inclusion in the Sulu admin panel (high 8.5)
- [CVE-2021-32737](https://insights.sbomify.com/CVE-2021-32737/): XSS Injection in Media Collection Title was possible (high 8.4)
- [CVE-2021-43835](https://insights.sbomify.com/CVE-2021-43835/): Privilege escalation in the Sulu Admin panel (high 7.2)
- [CVE-2021-41169](https://insights.sbomify.com/CVE-2021-41169/): Improper Neutralization HTML tags in sulu/sulu (medium 6.2)
- [CVE-2024-47617](https://insights.sbomify.com/CVE-2024-47617/): Reflected XSS Vulnerability in Sulu Media Bundle (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27915 and fix it if it is affected.

What it is: CVE-2024-27915 is a medium-severity missing authorization vulnerability in sulu, published on 6 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27915 in the wild and no public exploit code.

Affected packages and fixed versions:
- sulu/sulu (Packagist): affected from 2.2.0; fixed in 2.4.17
- sulu/sulu (Packagist): affected from 2.2.0; fixed in 2.4.17
- sulu/sulu (Packagist): affected from 2.5.0-alpha1; fixed in 2.5.13
- sulu/sulu (Packagist): affected from 2.5.0-alpha1; fixed in 2.5.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27915/ (Markdown: https://insights.sbomify.com/CVE-2024-27915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27915
- OSV: https://osv.dev/vulnerability/CVE-2024-27915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27915/
Summaries are generated and may contain mistakes; the official description above is the record.
