# CVE-2024-27917: Shopware's session is persistent in Cache for 404 pages

> Attackers can obtain valid session cookies from cached 404 pages, potentially leading to account takeover if Redis session storage is not configured.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-c2f9-4jmm-v45m

## What is CVE-2024-27917?

CVE-2024-27917 is a high-severity vulnerability in Shopware Shopware, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shopware is an open commerce platform based on Symfony Framework and Vue. The Symfony Session Handler pops the Session Cookie and assigns it to the Response. Since Shopware 6.5.8.0, the 404 pages are cached to improve the performance of 404 pages. So the cached Response which contains a Session Cookie when the Browser accessing the 404 page, has no cookies yet. The Symfony Session Handler is in use, when no explicit Session configuration has been done. When Redis is in use for Sessions using the PHP Redis extension, this exploiting code is not used. Shopware version 6.5.8.7 contains a patch for this issue. As a workaround, use Redis for Sessions, as this does not trigger the exploit code.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2024-27917?

4 open source packages ship an affected version, including shopware/platform and shopware/storefront. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/platform` | Packagist | From 6.5.8.0 | 6.5.8.7 |
| `shopware/platform` | Packagist | From 6.5.8.0 | 6.5.8.7 |
| `shopware/storefront` | Packagist | From 6.5.8.0 | 6.5.8.7 |
| `shopware/storefront` | Packagist | From 6.5.8.0 | 6.5.8.7 |

Products: Shopware Shopware.

## How do I fix CVE-2024-27917?

Upgrade shopware/platform to 6.5.8.7 or later.

## Is CVE-2024-27917 being exploited?

There is no known exploitation of CVE-2024-27917 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27917 and fix it if it is affected.

What it is: CVE-2024-27917 is a high-severity vulnerability in Shopware Shopware, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27917 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/platform (Packagist): affected from 6.5.8.0; fixed in 6.5.8.7
- shopware/platform (Packagist): affected from 6.5.8.0; fixed in 6.5.8.7
- shopware/storefront (Packagist): affected from 6.5.8.0; fixed in 6.5.8.7
- shopware/storefront (Packagist): affected from 6.5.8.0; fixed in 6.5.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27917/ (Markdown: https://insights.sbomify.com/CVE-2024-27917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27917
- OSV: https://osv.dev/vulnerability/CVE-2024-27917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27917/
Summaries are generated and may contain mistakes; the official description above is the record.
