CVE-2024-27919 HTTP/2: memory exhaustion due to CONTINUATION frame flood

High 7.5 Published Updated

An attacker can cause memory exhaustion and denial of service in Envoy by flooding HTTP/2 CONTINUATION frames, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-27919?

CVE-2024-27919 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Envoy is a cloud-native, open-source edge and service proxy. In versions 1.29.0 and 1.29.1, theEnvoy HTTP/2 protocol stack is vulnerable to the flood of CONTINUATION frames. Envoy's HTTP/2 codec does not reset a request when header map limits have been exceeded. This allows an attacker to send an sequence of CONTINUATION frames without the END_HEADERS bit set causing unlimited memory consumption. This can lead to denial of service through memory exhaustion. Users should upgrade to versions 1.29.2 to mitigate the effects of the CONTINUATION flood. Note that this vulnerability is a regression in Envoy version 1.29.0 and 1.29.1 only. As a workaround, downgrade to version 1.28.1 or earlier or disable HTTP/2 protocol for downstream connections.

Weakness: CWE-390

Which versions are affected by CVE-2024-27919?

1 open source package ship an affected version, including envoy. It affects 1 product.

PackageAffectedFixed in
envoy BitnamiFrom 1.29.01.29.2

Products include Envoyproxy Envoy.

How do I fix CVE-2024-27919?

Upgrade envoy to 1.29.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-27919 being exploited?

There is no known exploitation of CVE-2024-27919 in the wild and no public exploit code.

All Envoyproxy Envoy vulnerabilities

Sources

Also known as BIT-envoy-2024-27919, GHSA-gghf-vfxp-799r.

Is CVE-2024-27919 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free