# CVE-2024-27919: HTTP/2: memory exhaustion due to CONTINUATION frame flood

> An attacker can cause memory exhaustion and denial of service in Envoy by flooding HTTP/2 CONTINUATION frames, requiring an upgrade to mitigate.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2024
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-envoy-2024-27919, GHSA-gghf-vfxp-799r

## What is CVE-2024-27919?

CVE-2024-27919 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is a cloud-native, open-source edge and service proxy. In versions 1.29.0 and 1.29.1, theEnvoy HTTP/2 protocol stack is vulnerable to the flood of CONTINUATION frames. Envoy's HTTP/2 codec does not reset a request when header map limits have been exceeded. This allows an attacker to send an sequence of CONTINUATION frames without the END_HEADERS bit set causing unlimited memory consumption. This can lead to denial of service through memory exhaustion. Users should upgrade to versions 1.29.2 to mitigate the effects of the CONTINUATION flood. Note that this vulnerability is a regression in Envoy version 1.29.0 and 1.29.1 only. As a workaround, downgrade to version 1.28.1 or earlier or disable HTTP/2 protocol for downstream connections.

Weakness: CWE-390 (Detection of Error Condition Without Action)

## Which versions are affected by CVE-2024-27919?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | From 1.29.0 | 1.29.2 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2024-27919?

Upgrade envoy to 1.29.2 or later.

## Is CVE-2024-27919 being exploited?

There is no known exploitation of CVE-2024-27919 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27919 and fix it if it is affected.

What it is: CVE-2024-27919 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27919 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected from 1.29.0; fixed in 1.29.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27919/ (Markdown: https://insights.sbomify.com/CVE-2024-27919/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27919
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27919
- OSV: https://osv.dev/vulnerability/CVE-2024-27919

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27919/
Summaries are generated and may contain mistakes; the official description above is the record.
