# CVE-2024-27921: Grav File Upload Path Traversal vulnerability

> Attackers can exploit path traversal in Grav CMS to upload malicious files, leading to arbitrary code execution and data exfiltration.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2024
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-m7hx-hw6h-mqmc

## What is CVE-2024-27921?

CVE-2024-27921 is a high-severity path traversal vulnerability in Getgrav Grav, published on 21 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is an open-source, flat-file content management system. A file upload path traversal vulnerability has been identified in the application prior to version 1.7.45, enabling attackers to replace or create files with extensions like .json, .zip, .css, .gif, etc. This critical security flaw poses severe risks, that can allow attackers to inject arbitrary code on the server, undermine integrity of backup files by overwriting existing files or creating new ones, and exfiltrate sensitive data using CSS exfiltration techniques. Upgrading to patched version 1.7.45 can mitigate the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-27921?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.45 |
| `getgrav/grav` | Packagist | All versions | 1.7.45 |

Products: Getgrav Grav.

## How do I fix CVE-2024-27921?

Upgrade getgrav/grav to 1.7.45 or later.

## Is CVE-2024-27921 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27921 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27921 and fix it if it is affected.

What it is: CVE-2024-27921 is a high-severity path traversal vulnerability in Getgrav Grav, published on 21 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-27921 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.45
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.45

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27921/ (Markdown: https://insights.sbomify.com/CVE-2024-27921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27921
- OSV: https://osv.dev/vulnerability/CVE-2024-27921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27921/
Summaries are generated and may contain mistakes; the official description above is the record.
