{"answers":{"affected":"2 open source packages ship an affected version, including @tomphttp/bare-server-node. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-27922 in the wild and no public exploit code.","fix":"Upgrade @tomphttp/bare-server-node to 2.0.2 or later.","what":"CVE-2024-27922 is a critical vulnerability in tomphttp bare-server-node, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27922 and fix it if it is affected.\n\nWhat it is: CVE-2024-27922 is a critical vulnerability in tomphttp bare-server-node, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-27922 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @tomphttp/bare-server-node (npm): affected all versions; fixed in 2.0.2\n- @tomphttp/bare-server-node (npm): affected all versions; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27922/ (Markdown: https://insights.sbomify.com/CVE-2024-27922/index.md)","id":"CVE-2024-27922","markdown":"https://insights.sbomify.com/CVE-2024-27922/index.md","name":"CVE-2024-27922","record":{"aliases":["GHSA-86fc-f9gr-v533"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP proxy library","requires_auth":"none","summary":"Attackers can manipulate web traffic through insecure HTTP handling in the Bare server library, affecting users of the package.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"tomp_bare_server","vendor":"tomphttp"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"TOMP Bare Server implements the TompHTTP bare server. A vulnerability in versions prior to 2.0.2 relates to insecure handling of HTTP requests by the @tomphttp/bare-server-node package. This flaw potentially exposes the users of the package to manipulation of their web traffic. The impact may vary depending on the specific usage of the package but it can potentially affect any system where this package is in use. The problem has been patched in version 2.0.2. As of time of publication, no specific workaround strategies have been disclosed.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTTP Handling Vulnerability in the Bare server","id":"CVE-2024-27922","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Remote Code Execution by uploading a phar file using frontmatter","id":"CVE-2024-27923"},"packages":[{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"@tomphttp/bare-server-node","purl":null,"source":"GHSA-86fc-f9gr-v533"},{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"@tomphttp/bare-server-node","purl":"pkg:npm/%40tomphttp/bare-server-node","source":"GHSA-86fc-f9gr-v533"}],"prev":{"headline":"Grav File Upload Path Traversal vulnerability","id":"CVE-2024-27921"},"products":["bare-server-node"],"published":"2024-03-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["tomphttp"]},"summary":"Attackers can manipulate web traffic through insecure HTTP handling in the Bare server library, affecting users of the package.","url":"https://insights.sbomify.com/CVE-2024-27922/"}