# CVE-2024-27922: HTTP Handling Vulnerability in the Bare server

> Attackers can manipulate web traffic through insecure HTTP handling in the Bare server library, affecting users of the package.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-86fc-f9gr-v533

## What is CVE-2024-27922?

CVE-2024-27922 is a critical vulnerability in tomphttp bare-server-node, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TOMP Bare Server implements the TompHTTP bare server. A vulnerability in versions prior to 2.0.2 relates to insecure handling of HTTP requests by the @tomphttp/bare-server-node package. This flaw potentially exposes the users of the package to manipulation of their web traffic. The impact may vary depending on the specific usage of the package but it can potentially affect any system where this package is in use. The problem has been patched in version 2.0.2. As of time of publication, no specific workaround strategies have been disclosed.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-27922?

2 open source packages ship an affected version, including @tomphttp/bare-server-node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tomphttp/bare-server-node` | npm | All versions | 2.0.2 |
| `@tomphttp/bare-server-node` | npm | All versions | 2.0.2 |

Products: Tomphttp Tomp Bare Server.

## How do I fix CVE-2024-27922?

Upgrade @tomphttp/bare-server-node to 2.0.2 or later.

## Is CVE-2024-27922 being exploited?

There is no known exploitation of CVE-2024-27922 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27922 and fix it if it is affected.

What it is: CVE-2024-27922 is a critical vulnerability in tomphttp bare-server-node, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27922 in the wild and no public exploit code.

Affected packages and fixed versions:
- @tomphttp/bare-server-node (npm): affected all versions; fixed in 2.0.2
- @tomphttp/bare-server-node (npm): affected all versions; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27922/ (Markdown: https://insights.sbomify.com/CVE-2024-27922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27922
- OSV: https://osv.dev/vulnerability/CVE-2024-27922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27922/
Summaries are generated and may contain mistakes; the official description above is the record.
