CVE-2024-27926 RSSHub Cross-site Scripting vulnerability caused by internal media proxy

Medium 6.1 Published Updated

Attackers can execute arbitrary JavaScript via crafted images in the internal media proxy, affecting RSSHub users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-27926?

CVE-2024-27926 is a medium-severity cross-site scripting vulnerability in DIYgod RSSHub, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

RSSHub is an open source RSS feed generator. Starting in version 1.0.0-master.cbbd829 and prior to version 1.0.0-master.d8ca915, ahen the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code. Users who access the deliberately constructed URL are affected. This vulnerability was fixed in version 1.0.0-master.d8ca915. No known workarounds are available.

Weakness: CWE-79

Which versions are affected by CVE-2024-27926?

2 open source packages ship an affected version, including rsshub. It affects 1 product.

PackageAffectedFixed in
rsshub npmFrom 1.0.0-master.cbbd8291.0.0-master.d8ca915
rsshub npmFrom 1.0.0-master.cbbd8291.0.0-master.d8ca915

Products include Rsshub Rsshub.

How do I fix CVE-2024-27926?

Upgrade rsshub to 1.0.0-master.d8ca915 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-27926 being exploited?

There is no known exploitation of CVE-2024-27926 in the wild and no public exploit code.

Sources

Also known as GHSA-2wqw-hr4f-xrhh.

Is CVE-2024-27926 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free