{"answers":{"affected":"2 open source packages ship an affected version, including rsshub. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-27926 in the wild and no public exploit code.","fix":"Upgrade rsshub to 1.0.0-master.d8ca915 or later.","what":"CVE-2024-27926 is a medium-severity cross-site scripting vulnerability in DIYgod RSSHub, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-27926 and fix it if it is affected.\n\nWhat it is: CVE-2024-27926 is a medium-severity cross-site scripting vulnerability in DIYgod RSSHub, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-27926 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rsshub (npm): affected from 1.0.0-master.cbbd829; fixed in 1.0.0-master.d8ca915\n- rsshub (npm): affected from 1.0.0-master.cbbd829; fixed in 1.0.0-master.d8ca915\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27926/ (Markdown: https://insights.sbomify.com/CVE-2024-27926/index.md)","id":"CVE-2024-27926","markdown":"https://insights.sbomify.com/CVE-2024-27926/index.md","name":"CVE-2024-27926","record":{"aliases":["GHSA-2wqw-hr4f-xrhh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"RSS feed generator","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via crafted images in the internal media proxy, affecting RSSHub users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rsshub","vendor":"rsshub"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"RSSHub is an open source RSS feed generator. Starting in version 1.0.0-master.cbbd829 and prior to version 1.0.0-master.d8ca915, ahen the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code. Users who access the deliberately constructed URL are affected. This vulnerability was fixed in version 1.0.0-master.d8ca915. No known workarounds are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RSSHub Cross-site Scripting vulnerability caused by internal media proxy","id":"CVE-2024-27926","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"RSSHub vulnerable to SSRF in /mastodon, /zjoi, and /m4","id":"CVE-2024-27927"},"packages":[{"ecosystem":"npm","fixed":["1.0.0-master.d8ca915"],"introduced":["1.0.0-master.cbbd829"],"last_affected":[],"package":"rsshub","purl":null,"source":"GHSA-2wqw-hr4f-xrhh"},{"ecosystem":"npm","fixed":["1.0.0-master.d8ca915"],"introduced":["1.0.0-master.cbbd829"],"last_affected":[],"package":"rsshub","purl":"pkg:npm/rsshub","source":"GHSA-2wqw-hr4f-xrhh"}],"prev":{"headline":"Remote Code Execution by uploading a phar file using frontmatter","id":"CVE-2024-27923"},"products":["RSSHub"],"published":"2024-03-06","related":[{"cvss_score":8.8,"headline":"RSSHub is vulnerable to SSRF (Server-Side Request Forgery)","id":"CVE-2023-22493","kev_date_added":null,"published":"2023-01-13"},{"cvss_score":8.6,"headline":"Risk of code injection in RSSHub","id":"CVE-2021-21278","kev_date_added":null,"published":"2021-01-26"},{"cvss_score":6.5,"headline":"RSSHub vulnerable to SSRF in /mastodon, /zjoi, and /m4","id":"CVE-2024-27927","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":5.4,"headline":"RSSHub is vulnerable to cross-site scripting (XSS) via unvalidated URL parameters","id":"CVE-2023-26491","kev_date_added":null,"published":"2023-03-03"},{"cvss_score":5.3,"headline":"Denial of Service (DoS) vulnerability in RSSHub","id":"CVE-2022-31110","kev_date_added":null,"published":"2022-06-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-05","vendors":["DIYgod"]},"summary":"Attackers can execute arbitrary JavaScript via crafted images in the internal media proxy, affecting RSSHub users.","url":"https://insights.sbomify.com/CVE-2024-27926/"}