# CVE-2024-27926: RSSHub Cross-site Scripting vulnerability caused by internal media proxy

> Attackers can execute arbitrary JavaScript via crafted images in the internal media proxy, affecting RSSHub users.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2wqw-hr4f-xrhh

## What is CVE-2024-27926?

CVE-2024-27926 is a medium-severity cross-site scripting vulnerability in DIYgod RSSHub, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

RSSHub is an open source RSS feed generator. Starting in version 1.0.0-master.cbbd829 and prior to version 1.0.0-master.d8ca915, ahen the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code. Users who access the deliberately constructed URL are affected. This vulnerability was fixed in version 1.0.0-master.d8ca915. No known workarounds are available.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-27926?

2 open source packages ship an affected version, including rsshub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rsshub` | npm | From 1.0.0-master.cbbd829 | 1.0.0-master.d8ca915 |
| `rsshub` | npm | From 1.0.0-master.cbbd829 | 1.0.0-master.d8ca915 |

Products: Rsshub Rsshub.

## How do I fix CVE-2024-27926?

Upgrade rsshub to 1.0.0-master.d8ca915 or later.

## Is CVE-2024-27926 being exploited?

There is no known exploitation of CVE-2024-27926 in the wild and no public exploit code.

## Other vulnerabilities in DIYgod RSSHub

- [CVE-2023-22493](https://insights.sbomify.com/CVE-2023-22493/): RSSHub is vulnerable to SSRF (Server-Side Request Forgery) (high 8.8)
- [CVE-2021-21278](https://insights.sbomify.com/CVE-2021-21278/): Risk of code injection in RSSHub (high 8.6)
- [CVE-2024-27927](https://insights.sbomify.com/CVE-2024-27927/): RSSHub vulnerable to SSRF in /mastodon, /zjoi, and /m4 (medium 6.5)
- [CVE-2023-26491](https://insights.sbomify.com/CVE-2023-26491/): RSSHub is vulnerable to cross-site scripting (XSS) via unvalidated URL parameters (medium 5.4)
- [CVE-2022-31110](https://insights.sbomify.com/CVE-2022-31110/): Denial of Service (DoS) vulnerability in RSSHub (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27926 and fix it if it is affected.

What it is: CVE-2024-27926 is a medium-severity cross-site scripting vulnerability in DIYgod RSSHub, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-27926 in the wild and no public exploit code.

Affected packages and fixed versions:
- rsshub (npm): affected from 1.0.0-master.cbbd829; fixed in 1.0.0-master.d8ca915
- rsshub (npm): affected from 1.0.0-master.cbbd829; fixed in 1.0.0-master.d8ca915

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27926/ (Markdown: https://insights.sbomify.com/CVE-2024-27926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27926
- OSV: https://osv.dev/vulnerability/CVE-2024-27926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27926/
Summaries are generated and may contain mistakes; the official description above is the record.
