# CVE-2024-27927: RSSHub vulnerable to SSRF in /mastodon, /zjoi, and /m4

> Attackers can exploit RSSHub to send arbitrary HTTP GET requests, enabling internal network scanning, data leakage, and denial-of-service attacks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2024
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-3p3p-cgj7-vgw3

## What is CVE-2024-27927?

CVE-2024-27927 is a medium-severity server-side request forgery vulnerability in DIYgod RSSHub, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RSSHub is an open source RSS feed generator. Prior to version 1.0.0-master.a429472, RSSHub allows remote attackers to use the server as a proxy to send HTTP GET requests to arbitrary targets and retrieve information in the internal network or conduct Denial-of-Service (DoS) attacks. The attacker can send malicious requests to a RSSHub server, to make the server send HTTP GET requests to arbitrary destinations and see partial responses. This may lead to leak the server IP address, which could be hidden behind a CDN; retrieving information in the internal network, e.g. which addresses/ports are accessible, the titles and meta descriptions of HTML pages; and denial of service amplification. The attacker could request the server to download some large files, or chain several SSRF requests in a single attacker request.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-27927?

2 open source packages ship an affected version, including rsshub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rsshub` | npm | All versions | 1.0.0-master.a429472 |
| `rsshub` | npm | All versions | 1.0.0-master.a429472 |

Products: Rsshub Rsshub.

## How do I fix CVE-2024-27927?

Upgrade rsshub to 1.0.0-master.a429472 or later.

## Is CVE-2024-27927 being exploited?

There is no known exploitation of CVE-2024-27927 in the wild and no public exploit code.

## Other vulnerabilities in DIYgod RSSHub

- [CVE-2023-22493](https://insights.sbomify.com/CVE-2023-22493/): RSSHub is vulnerable to SSRF (Server-Side Request Forgery) (high 8.8)
- [CVE-2021-21278](https://insights.sbomify.com/CVE-2021-21278/): Risk of code injection in RSSHub (high 8.6)
- [CVE-2024-27926](https://insights.sbomify.com/CVE-2024-27926/): RSSHub Cross-site Scripting vulnerability caused by internal media proxy (medium 6.1)
- [CVE-2023-26491](https://insights.sbomify.com/CVE-2023-26491/): RSSHub is vulnerable to cross-site scripting (XSS) via unvalidated URL parameters (medium 5.4)
- [CVE-2022-31110](https://insights.sbomify.com/CVE-2022-31110/): Denial of Service (DoS) vulnerability in RSSHub (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27927 and fix it if it is affected.

What it is: CVE-2024-27927 is a medium-severity server-side request forgery vulnerability in DIYgod RSSHub, published on 6 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27927 in the wild and no public exploit code.

Affected packages and fixed versions:
- rsshub (npm): affected all versions; fixed in 1.0.0-master.a429472
- rsshub (npm): affected all versions; fixed in 1.0.0-master.a429472

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27927/ (Markdown: https://insights.sbomify.com/CVE-2024-27927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27927
- OSV: https://osv.dev/vulnerability/CVE-2024-27927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27927/
Summaries are generated and may contain mistakes; the official description above is the record.
