{"answers":{"affected":"3 open source packages ship an affected version, including vantage6.","exploited":"There is no known exploitation of CVE-2024-27928 in the wild and no public exploit code.","fix":"Upgrade vantage6 to 5.0.0 or later.","what":"CVE-2024-27928 is a medium-severity vulnerability in vantage6, published on 17 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-27928 and fix it if it is affected.\n\nWhat it is: CVE-2024-27928 is a medium-severity vulnerability in vantage6, published on 17 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-27928 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vantage6 (PyPI): affected all versions; fixed in 5.0.0\n- vantage6 (PyPI): affected all versions; fixed in 5.0.0\n- vantage6 (PyPI): affected all versions; fixed in 5.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-27928/ (Markdown: https://insights.sbomify.com/CVE-2024-27928/index.md)","id":"CVE-2024-27928","markdown":"https://insights.sbomify.com/CVE-2024-27928/index.md","name":"CVE-2024-27928","record":{"aliases":["GHSA-4c5c-2vc3-x5w2","PYSEC-2026-3398"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"vantage6 infrastructure","requires_auth":"high_privilege","summary":"Attackers with email access can bypass two-factor authentication by resetting both password and 2FA tokens via email, compromising user accounts.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-308","name":"Use of Single-factor Authentication"}],"description":"vantage6 is an open-source infrastructure for privacy preserving analysis. Prior to version 5.0.0, if an attacker hacks into a vantage6 user's email account, they can 1) reset the password via email and then 2) reset the 2FA token via email. This way they reduce 2FA to 1FA (email access). Note that most email providers require 2FA to access email, so this issue is not very likely to cause issues. Version 5.0.0 fixes the issue. No known workarounds are available.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vantage6: 2FA can be circumvented with hacked email access","id":"CVE-2024-27928","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Use After Free in SixLabors.ImageSharp","id":"CVE-2024-27929"},"packages":[{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"vantage6","purl":null,"source":"GHSA-4c5c-2vc3-x5w2"},{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"vantage6","purl":"pkg:pypi/vantage6","source":"GHSA-4c5c-2vc3-x5w2"},{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"vantage6","purl":"pkg:pypi/vantage6","source":"PYSEC-2026-3398"}],"prev":{"headline":"RSSHub vulnerable to SSRF in /mastodon, /zjoi, and /m4","id":"CVE-2024-27927"},"products":["vantage6"],"published":"2026-06-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-18","vendors":["vantage6"]},"summary":"Attackers with email access can bypass two-factor authentication by resetting both password and 2FA tokens via email, compromising user accounts.","url":"https://insights.sbomify.com/CVE-2024-27928/"}