# CVE-2024-27928: Vantage6: 2FA can be circumvented with hacked email access

> Attackers with email access can bypass two-factor authentication by resetting both password and 2FA tokens via email, compromising user accounts.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-4c5c-2vc3-x5w2, PYSEC-2026-3398

## What is CVE-2024-27928?

CVE-2024-27928 is a medium-severity vulnerability in vantage6, published on 17 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

vantage6 is an open-source infrastructure for privacy preserving analysis. Prior to version 5.0.0, if an attacker hacks into a vantage6 user's email account, they can 1) reset the password via email and then 2) reset the 2FA token via email. This way they reduce 2FA to 1FA (email access). Note that most email providers require 2FA to access email, so this issue is not very likely to cause issues. Version 5.0.0 fixes the issue. No known workarounds are available.

Weakness: CWE-308 (Use of Single-factor Authentication)

## Which versions are affected by CVE-2024-27928?

3 open source packages ship an affected version, including vantage6.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 5.0.0 |
| `vantage6` | PyPI | All versions | 5.0.0 |
| `vantage6` | PyPI | All versions | 5.0.0 |

## How do I fix CVE-2024-27928?

Upgrade vantage6 to 5.0.0 or later.

## Is CVE-2024-27928 being exploited?

There is no known exploitation of CVE-2024-27928 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-27928 and fix it if it is affected.

What it is: CVE-2024-27928 is a medium-severity vulnerability in vantage6, published on 17 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-27928 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 5.0.0
- vantage6 (PyPI): affected all versions; fixed in 5.0.0
- vantage6 (PyPI): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-27928/ (Markdown: https://insights.sbomify.com/CVE-2024-27928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-27928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-27928
- OSV: https://osv.dev/vulnerability/CVE-2024-27928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-27928/
Summaries are generated and may contain mistakes; the official description above is the record.
